summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-10-16 14:31:35 +0200
committerMatthew Brewer <tomboy64@sina.cn>2015-10-17 13:11:13 +0200
commitf379f261451d9a6bef0ee96e48a32249c2fffdee (patch)
treea7acfc0a5ae316ae2fc8dc4ab25e2bb722d71b53 /dev-ml/ocaml-cstruct
parentsys-libs/glibc: more upstream fixes (diff)
downloadgentoo-f379f261451d9a6bef0ee96e48a32249c2fffdee.tar.gz
gentoo-f379f261451d9a6bef0ee96e48a32249c2fffdee.tar.bz2
gentoo-f379f261451d9a6bef0ee96e48a32249c2fffdee.zip
dev-ml/ocaml-cstruct: new ebuild
- needed as a transitive dependency of Libre S3 1.1 (net-misc/libres3) - explicit support for MirageOS is not enabled known issue: dev-ml/ocaml-cstruct-1.7.0 fails to build with USE=doc ( https://github.com/mirage/ocaml-cstruct/issues/73 )
Diffstat (limited to 'dev-ml/ocaml-cstruct')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/metadata.xml14
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0.ebuild43
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
new file mode 100644
index 000000000000..d7a9c7a00f97
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -0,0 +1 @@
+DIST ocaml-cstruct-1.7.0.tar.gz 245652 SHA256 db996700df500cff933eaaebfff9834ccaba466518bade575934bb133f62f322 SHA512 5a43ffa0ee867c917f171cd90186eaf44a258f1e4fb9db7947d23113fe7d8e9058acfce7030c0e31e211b5448a9e23b48ad748c61ffab6678aa79c6aeaac2f48 WHIRLPOOL 99d7650405df68d8e4d1cfc237eb9a791db5c54cfcdbbf2e9eb5c493881256eed7298588c6ad9ca91b493544df0bb24e9c87c2820c5b92c37d460a8cc6211c26
diff --git a/dev-ml/ocaml-cstruct/metadata.xml b/dev-ml/ocaml-cstruct/metadata.xml
new file mode 100644
index 000000000000..4913ab22f85c
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tomboy64@sina.cn</email>
+ </maintainer>
+ <use>
+ <flag name="async">Support for asynchronous execution</flag>
+ <flag name="camlp4">Enable support for camlp4</flag>
+ <flag name="lwt">Enable threads via lwt</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0.ebuild
new file mode 100644
index 000000000000..b137031b31f8
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="async camlp4 lwt"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ camlp4? ( dev-ml/camlp4:= )
+ lwt? ( dev-ml/lwt:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable camlp4)
+ $(use_enable async)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )