summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-17 15:42:04 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-17 15:42:43 +0200
commite908b08a06e6078c861cbe5e9202050eecfd09be (patch)
treef434ee82e65f9b1da1bd5e17b4a93b89804fb127 /dev-ml/ocaml-ctypes
parentdev-db/pgcli: add 4.1.0 (diff)
downloadgentoo-e908b08a06e6078c861cbe5e9202050eecfd09be.tar.gz
gentoo-e908b08a06e6078c861cbe5e9202050eecfd09be.tar.bz2
gentoo-e908b08a06e6078c861cbe5e9202050eecfd09be.zip
dev-ml/ocaml-ctypes: add 0.23.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.23.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 4031632b920e..6c19bdcb97bc 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -3,3 +3,4 @@ DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c
DIST ocaml-ctypes-0.20.1.tar.gz 206863 BLAKE2B a101872991d4bd83464d26e79fa5052c9dadbd10da1ae734fda8976199640091939777a1ba391d2aab84d7e14fafec6f713681e2ea52f6717f5f36d26e8aa225 SHA512 f95e65ce5003a07634afcbee431cb23c54c8335f926074615fc8d76ab777b9d2fce8f75bb25bbb6ed9550a7d6237fb377aa9ad65a426d2d7e387f86c1158fe4a
DIST ocaml-ctypes-0.21.1.tar.gz 200264 BLAKE2B c4539c8856c1919194f11ecaeb1b0649dc701a6c0dda62c4bb750cd64a9145f2e4a9e77392385e4e398e8e89d5ae91b7c5f68b6242f826563f0f32b78497dfe1 SHA512 3a64b29746360e7dda7725ce7af23ca64cd6a3fa585aa70188cdd143aace744f44c1bd13cdda5c9733ca53d4b874ed42749ca21aaff4f4d53636a390a2c7f94f
DIST ocaml-ctypes-0.22.0.tar.gz 200377 BLAKE2B f9a27434a564d619d45bc4bd74fa0e045b21cf62e7b83203f25757e093e0ebff6b259b871eec57e404a3b043e4bbfc433a664d78e64b4b357730e09371a0d220 SHA512 98925bddfba81fd91383c5ee87a47f8f3424958e0affc299585b83029ce3cc52ac4c059f94d548cb15f37379ba3a8742a04b94f76787177b26c233b7037faa09
+DIST ocaml-ctypes-0.23.0.tar.gz 200133 BLAKE2B c079c64584a2293ee0ef3d3a2d08472728ff3891b65773a97c23af0039dd4693b3c909d969ac006c976bad9af8b2743dfa03acddb8ed74f2405e60ef1cdb0f40 SHA512 0c287cd3162d092b37bd6d4b24c196d41c93b792c4aa77938fde60f5dbc7eedde588097493a645af9bffc0ed722eadd0fa90e04b04d5e36e78e6467ae9e4baf8
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.23.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.23.0.ebuild
new file mode 100644
index 000000000000..fbec82b5da87
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.23.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ctypes
+inherit dune
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/yallop/ocaml-ctypes/"
+SRC_URI="https://github.com/yallop/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+REQUIRED_USE="ocamlopt"
+
+src_install() {
+ dune-install ctypes ctypes-foreign
+}