summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-26 17:04:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-26 18:59:02 +0200
commitbccd86322a23c27820c4a676604662c16809ee5c (patch)
tree59480a958bd1bdacef2a5353baf32c1b041e8ea3 /dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild
parentdev-ros/geometric_shapes: bump to 0.5.1 (diff)
downloadgentoo-bccd86322a23c27820c4a676604662c16809ee5c.tar.gz
gentoo-bccd86322a23c27820c4a676604662c16809ee5c.tar.bz2
gentoo-bccd86322a23c27820c4a676604662c16809ee5c.zip
dev-ml/ocaml-redis: bump to 0.3.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild')
-rw-r--r--dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild b/dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild
new file mode 100644
index 000000000000..7f07088fca6a
--- /dev/null
+++ b/dev-ml/ocaml-redis/ocaml-redis-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+RDEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/uuidm:=
+ lwt? ( dev-ml/lwt:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" oasis_src_configure
+}