summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-02 12:54:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-03 17:13:26 +0200
commitf9f72e276f3c3ca835a93ca5d9467684383ca96c (patch)
tree23bf835d62b95e91c241ffa5cfed69670486c8eb /dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
parentdev-ml/reason-parser: remove old (diff)
downloadgentoo-f9f72e276f3c3ca835a93ca5d9467684383ca96c.tar.gz
gentoo-f9f72e276f3c3ca835a93ca5d9467684383ca96c.tar.bz2
gentoo-f9f72e276f3c3ca835a93ca5d9467684383ca96c.zip
dev-ml/ocaml-uri: bump to 1.9.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild')
-rw-r--r--dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
new file mode 100644
index 000000000000..d7a33a6f362e
--- /dev/null
+++ b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="RFC3986 URI parsing library for OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-uri https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/stringext:=
+ dev-ml/type-conv:=
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ uri.install || die
+}