summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-14 00:22:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-14 00:26:19 +0200
commit844662b66f65e88ea8bce1d33108599f4fe6a7e4 (patch)
tree42e342f3f4e5fc283e06ed95bd67f7d897647c7f /dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
parentdev-util/artifactory-bin: version bump, 5.3.2 / 5.4.4 (diff)
downloadgentoo-844662b66f65e88ea8bce1d33108599f4fe6a7e4.tar.gz
gentoo-844662b66f65e88ea8bce1d33108599f4fe6a7e4.tar.bz2
gentoo-844662b66f65e88ea8bce1d33108599f4fe6a7e4.zip
dev-ml/ppx_deriving_yojson: fix build with ocaml 4.05
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild')
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
index c6b55db684d0..f2a359e34704 100644
--- a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+inherit eutils
+
DESCRIPTION="A Yojson codec generator for OCaml"
HOMEPAGE="https://github.com/whitequark/ppx_deriving_yojson/"
SRC_URI="https://github.com/whitequark/ppx_deriving_yojson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -25,6 +27,10 @@ DEPEND="${DEPEND}
dev-ml/ocamlbuild
test? ( dev-ml/ounit dev-ml/ppx_import )"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.05_rc' && epatch "${FILESDIR}/ocaml405.patch"
+}
+
src_compile() {
cp pkg/META.in pkg/META
ocaml pkg/build.ml \