summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-18 08:06:40 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-18 08:07:02 +0200
commit7a9fdfbebec49680493913f10691ca3b6ed5117a (patch)
tree1c45fc075f265d69a4fb46c7cdf62caf2da5a722 /dev-ml
parentdev-ml/opam: add 2.1.6 (diff)
downloadgentoo-7a9fdfbebec49680493913f10691ca3b6ed5117a.tar.gz
gentoo-7a9fdfbebec49680493913f10691ca3b6ed5117a.tar.bz2
gentoo-7a9fdfbebec49680493913f10691ca3b6ed5117a.zip
dev-ml/opam-installer: add 2.1.6
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index a004a07b0e44..5e20fd641bc5 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -4,3 +4,4 @@ DIST opam-full-2.0.9.tar.gz 8029605 BLAKE2B c2ae06bdbbdbe9db270ec0027ec8d13a228f
DIST opam-full-2.1.2.tar.gz 9442446 BLAKE2B fe5447fe8f9bcedb30bf455e93b54a37e950e2944f6f501545bdccf6d989de2da90106938efb6a12c1b9454ecefed5be9906d65a15a4d0244302ad7ccff170db SHA512 fe12aaa27168435a978c472926d40697af0a7619a529c4bfacd0b71469dfcd534f43164bc74f60f740a735d38a869ae5e87e2414119f4f3fc1826315e8a075cd
DIST opam-full-2.1.3.tar.gz 9618995 BLAKE2B 6f33e70c2e59be87b643840128b46441828d3d83888f5d321ac23d33b2fbc4d3163cb4303ac82a7f863abcc9300227bbc48bca3b8db5d6fbcebf0e6cf8869a5d SHA512 fe3a3c86335830944683a39a34a9eb385037476853ab3e2a82b8571a9e2021830cccf25cbd5bb891d239f6a47584c1b1d91aa445e6e2a814847346c5cc526ff1
DIST opam-full-2.1.5.tar.gz 10801367 BLAKE2B 5e6b1140e279931dfb61f68d0c4888cb14d05ff610e2b151115efe6b6420d74e7079894b6f4360f377b155008530ba4ace9708bc9d1e1d8c13950c0a5be4de11 SHA512 e4e33fcee0a9f922f8b43c6b095554a946559a2c50341326d21cca0f24fc7105c0de01db204b408240b12b267c9929435e2c511adf140618c91873f10444ae90
+DIST opam-full-2.1.6.tar.gz 11704198 BLAKE2B 20e74551760cadf1d911e72c34502e1e7e62003f8ebc83f3b9cb46c712e13fb5f85f41421cc74b051c2e348e0c0a17f4ea34bf655f7ec48cfcdab1e0d8a57a11 SHA512 2bb24db05dc39d6e8294c10b5a6bb2dd8f675a4d56e1dc9a2e9bc576f54d14a1709005219c25586df9382897ab7ba5ea0636765410f01c06958ec59be9f14b4c
diff --git a/dev-ml/opam-installer/opam-installer-2.1.6.ebuild b/dev-ml/opam-installer/opam-installer-2.1.6.ebuild
new file mode 100644
index 000000000000..c8d56c6f4111
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ ~dev-ml/opam-${PV}:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ dune-compile ${PN}
+}