summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-30 15:34:11 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-30 15:38:50 +1300
commit2b80e4786314b536fffb4487ae522ecc8e0fbfbb (patch)
tree9ecc9824cdd475c9f0ca970f028d175c89ab1f30 /dev-perl/Authen-Radius
parentdev-perl/Bio-Graphics: Fix minor bump quirks (diff)
downloadgentoo-2b80e4786314b536fffb4487ae522ecc8e0fbfbb.tar.gz
gentoo-2b80e4786314b536fffb4487ae522ecc8e0fbfbb.tar.bz2
gentoo-2b80e4786314b536fffb4487ae522ecc8e0fbfbb.zip
dev-perl/Authen-Radius: Bump to version 0.260.0
- EAPI6 - Update patches for eapply format - Patchify sed code - Don't run export in global scope - Parallel tests Upstream: - Clear authenticator under clear_attributes() - Add support for changing I/O activity timeouts - Add ACCESS_CHALLENGE packet type definition - Fix large wait on processing broadcasts - Add support for Status-Server requests - Add support for IPv6 - Add support for integer64 - Fix warning using uninitialized $vendor_name - Add support for date and time types - Improve support for FreeRADIUS and GNU Radius dictionarty files - Add support for tagged attributes - Fix sublist attribute type encoding Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Authen-Radius')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild48
-rw-r--r--dev-perl/Authen-Radius/Manifest1
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch28
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch43
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
new file mode 100644
index 000000000000..93ca6b83ed0f
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
index 3642180cf55a..a69b438b9f7b 100644
--- a/dev-perl/Authen-Radius/Manifest
+++ b/dev-perl/Authen-Radius/Manifest
@@ -1 +1,2 @@
+DIST Authen-Radius-0.26.tar.gz 49432 BLAKE2B 05ce64cf463faa1ad1004a659859961d6df24d0651a180603a5a5fc3d672a91f8df521f7d19bbc7b62aa0d63e1ae5b54dec3d46718973ee160f3e7bae5f15d02 SHA512 6779712cd4fdc45115c6e68766ef58c8b1dc9bf3037f3e0e243bc23318d13b09104df5f825b40ce26f7eebe52e6c4887efc8525334f2ab00da23fe76322f0b56
DIST RadiusPerl-0.22.tar.gz 40980 BLAKE2B 5c8a1870d7a95c89f9f2b8546c0285b5cf62873b3960ee67d45db3c9edfa0117fc40f3238d42a1306a15c4740e739381ae7bb88234bfceff2a79d73a84e384f1 SHA512 d5c7327fa3d4b6f74405e905f01be23479be542073d035c3babc34b63577069f6069e44dda9709b69b5dc25552170a764eb02ab6d2b6c2f7b366da566ae8e967
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
new file mode 100644
index 000000000000..19d6b0ed9ca1
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
@@ -0,0 +1,28 @@
+From c3955cd5e9232cf891500cdddf96c0f4e336029b Mon Sep 17 00:00:00 2001
+From: Patrick Lauer <patrick@gentoo.org>
+Date: Mon, 29 Oct 2012 21:02:39 +1300
+Subject: Add ISG support to raddb cisco dictionary
+
+---
+ raddb/dictionary.cisco | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/raddb/dictionary.cisco b/raddb/dictionary.cisco
+index 4dadaa3..8d57a03 100644
+--- a/raddb/dictionary.cisco
++++ b/raddb/dictionary.cisco
+@@ -118,3 +118,11 @@ VALUE Cisco-Disconnect-Cause Session-Failed-Security 101
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
+--
+2.15.1
+
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
new file mode 100644
index 000000000000..746ba993defc
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
@@ -0,0 +1,43 @@
+From 57b9f1a710c2eee1c8f54eb87d164584aa9532ce Mon Sep 17 00:00:00 2001
+From: Torsten Veller <tove@gentoo.org>
+Date: Mon, 5 Nov 2012 01:02:48 +1300
+Subject: Remove automatic radis-db installer code
+
+---
+ MANIFEST | 1 -
+ Makefile.PL | 1 -
+ install-radius-db.PL => install-radius-db.PL.orig | 0
+ 3 files changed, 2 deletions(-)
+ rename install-radius-db.PL => install-radius-db.PL.orig (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index a8e2801..09913da 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -4,7 +4,6 @@ README
+ LICENSE
+ MANIFEST
+ Radius.pm
+-install-radius-db.PL
+ t/decode.t
+ t/dictionary.t
+ t/digest.t
+diff --git a/Makefile.PL b/Makefile.PL
+index 45653ab..7f1b202 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -4,7 +4,6 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => 'Authen::Radius',
+ VERSION_FROM => 'Radius.pm', # finds $VERSION
+- PPM_INSTALL_SCRIPT => 'install-radius-db.PL',
+ MIN_PERL_VERSION => "v5.10",
+ BUILD_REQUIRES => {
+ # Support for TEST_REQUIRES
+diff --git a/install-radius-db.PL b/install-radius-db.PL.orig
+similarity index 100%
+rename from install-radius-db.PL
+rename to install-radius-db.PL.orig
+--
+2.15.1
+