summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 05:26:07 +0100
committerSam James <sam@gentoo.org>2024-05-22 05:34:28 +0100
commit1b2014561e59ff5439302d792d1b3920748af5ff (patch)
tree82d6cd76333fde61be104eb0d1597e52a08cd0fd /dev-perl/B-OPCheck
parentdev-perl/B-Hooks-Parser: EAPI 8, rely on eclass impls (diff)
downloadgentoo-1b2014561e59ff5439302d792d1b3920748af5ff.tar.gz
gentoo-1b2014561e59ff5439302d792d1b3920748af5ff.tar.bz2
gentoo-1b2014561e59ff5439302d792d1b3920748af5ff.zip
dev-perl/B-OPCheck: EAPI 8, rely on eclass impls
This covers more variables/args, etc. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/B-OPCheck')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.320.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r2.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r2.ebuild
new file mode 100644
index 000000000000..7a555c7cc83a
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.80.0
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Scope-Guard
+ virtual/perl-XSLoader
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ virtual/perl-Test-Simple
+ )
+"