summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Clone
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Clone')
-rw-r--r--dev-perl/Clone/Clone-0.370.0.ebuild17
-rw-r--r--dev-perl/Clone/Clone-0.380.0.ebuild24
-rw-r--r--dev-perl/Clone/Manifest2
-rw-r--r--dev-perl/Clone/metadata.xml9
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-perl/Clone/Clone-0.370.0.ebuild b/dev-perl/Clone/Clone-0.370.0.ebuild
new file mode 100644
index 000000000000..05b7c1f29537
--- /dev/null
+++ b/dev-perl/Clone/Clone-0.370.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GARU
+MODULE_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Recursively copy Perl datatypes"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+SRC_TEST="do"
+mymake='OPTIMIZE=${CFLAGS}'
diff --git a/dev-perl/Clone/Clone-0.380.0.ebuild b/dev-perl/Clone/Clone-0.380.0.ebuild
new file mode 100644
index 000000000000..2b9f0e70b694
--- /dev/null
+++ b/dev-perl/Clone/Clone-0.380.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GARU
+MODULE_VERSION=0.38
+inherit perl-module
+
+DESCRIPTION="Recursively copy Perl datatypes"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do"
+mymake='OPTIMIZE=${CFLAGS}'
diff --git a/dev-perl/Clone/Manifest b/dev-perl/Clone/Manifest
new file mode 100644
index 000000000000..15031533563c
--- /dev/null
+++ b/dev-perl/Clone/Manifest
@@ -0,0 +1,2 @@
+DIST Clone-0.37.tar.gz 13369 SHA256 d9f251e6f01deaac3d29df1b8422b83dca972af999cd3f6ae456e0fc6f87cd9d SHA512 a47760938d826c28d6db2b3486238acff255c6e1c77ec797e93b4a9350a3cd5c3e730352f00675589594e4ec250ceb978990a10156669813933debce93f59266 WHIRLPOOL 7edd99560e83e0d0ea62e02b9f0409d305b565bd5ccd6e8ac6be6cc6b8db318081451b256cad98325ccb49dd12dcfa80d6f3629eee56a74134d1d7dcac2f10cd
+DIST Clone-0.38.tar.gz 13636 SHA256 9fb0534bb7ef6ca1f6cc1dc3f29750d6d424394d14c40efdc77832fad3cebde8 SHA512 6e40547255eab43e7d2e43b745292277951cecc227f92c58246e3959395e6c23b13c25568c90012a851c6ad2e6173b5bc988664cdde54f2ca881c50b0108c766 WHIRLPOOL d36a96a4d5bcef4fd0dc62dd722976217bd61af74556ba1e52c0ae0a8a4d481e96b985ff2b9abd4e61cf47bf016e3e7d2bf88f08f0ccd201f5abb67080691e6f
diff --git a/dev-perl/Clone/metadata.xml b/dev-perl/Clone/metadata.xml
new file mode 100644
index 000000000000..291e6c5ea740
--- /dev/null
+++ b/dev-perl/Clone/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Clone</remote-id>
+ <remote-id type="cpan-module">Clone</remote-id>
+ </upstream>
+</pkgmetadata>