summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-27 20:42:17 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-27 20:43:05 +1200
commit05da521163685396a567f3073a0a8f5afc0fbac2 (patch)
tree44c8f3dbd1df14d2ee1c3dbf1d933e957603a7eb /dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild
parentmedia-gfx/sane-backends: update variable in 1.0.30 (diff)
downloadgentoo-05da521163685396a567f3073a0a8f5afc0fbac2.tar.gz
gentoo-05da521163685396a567f3073a0a8f5afc0fbac2.tar.bz2
gentoo-05da521163685396a567f3073a0a8f5afc0fbac2.zip
dev-perl/Config-IniFiles: Bump to version 3.0.3
- EAPI7 Upstream: - Remove firstload/reload logic - Cache section hashes in the tie interface - Implement -php_compat - Remove author test scripts from t/ - Fix error with missing heredoc marker - Throw error on failed close() before rename() to overwrite the file - Allow overriding chmod() file permissions Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild')
-rw-r--r--dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild b/dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild
new file mode 100644
index 000000000000..95751383bc0a
--- /dev/null
+++ b/dev-perl/Config-IniFiles/Config-IniFiles-3.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=3.000003
+inherit perl-module
+
+DESCRIPTION="A module for reading .ini-style configuration files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# needs List::Util and Scalar::Util
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ dev-perl/IO-stringy
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-parent
+ )
+"