summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-17 17:14:09 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-17 17:14:43 +1200
commit52f5b5f9e806be83477d3f150f62a7918f037e70 (patch)
tree8e748e656fdbf065ae5d55f1ba5e6ae9510560ac /dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild
parentdev-python/subunit: Remove old (diff)
downloadgentoo-52f5b5f9e806be83477d3f150f62a7918f037e70.tar.gz
gentoo-52f5b5f9e806be83477d3f150f62a7918f037e70.tar.bz2
gentoo-52f5b5f9e806be83477d3f150f62a7918f037e70.zip
dev-perl/Data-Perl: Bump to version 0.2.11
- EAPI7 - Strip bad tests Upstream: - Add 'test' and 'tail' methods for Array Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild')
-rw-r--r--dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild b/dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild
new file mode 100644
index 000000000000..a6e0acd5d629
--- /dev/null
+++ b/dev-perl/Data-Perl/Data-Perl-0.2.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.002011
+inherit perl-module
+
+DESCRIPTION="Base classes wrapping fundamental Perl data types"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Class-Method-Modifiers
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Runtime
+ dev-perl/Role-Tiny
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+ dev-perl/strictures
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ dev-perl/Test-Output
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-coverage.t"
+ "t/author-pod-syntax.t"
+)