summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-08 13:42:52 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-08 13:42:52 +1200
commit98b01a81c450972efc9738f60a0d79d02cb0fe15 (patch)
tree30f16aaacb4d39a99d568526e9cc30057a8c5b8d /dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild
parentdev-perl/Devel-CheckLib: Bump to version 1.100.0 (diff)
downloadgentoo-98b01a81c450972efc9738f60a0d79d02cb0fe15.tar.gz
gentoo-98b01a81c450972efc9738f60a0d79d02cb0fe15.tar.bz2
gentoo-98b01a81c450972efc9738f60a0d79d02cb0fe15.zip
dev-perl/DateTime-Format-W3CDTF: Bump to version 0.70.0
- EAPI6 - Fix really wrong deps - Cleanup Pod tests Upstream: - Fix for '.' in @INC Bug: https://bugs.gentoo.org/614962 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild b/dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild
new file mode 100644
index 000000000000..df012ee0a9ef
--- /dev/null
+++ b/dev-perl/DateTime-Format-W3CDTF/DateTime-Format-W3CDTF-0.70.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GWILLIAMS
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Parse and format W3CDTF datetime strings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/DateTime"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ >=virtual/perl-Test-Simple-0.610.0
+ )
+"
+src_prepare() {
+ use test && perl_rm_files t/pod.t t/pod_coverage.t
+ perl-module_src_prepare
+}