summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-25 07:19:32 +0100
committerSam James <sam@gentoo.org>2024-05-25 07:21:48 +0100
commit960f2f9dfd64f4685228da7f2c2ab3dd3a1efa98 (patch)
treeeed7353a19661995d1bf956fc6140b1fe57c2626 /dev-perl/GnuPG-Interface
parentdev-perl/GnuPG-Interface: don't call which (diff)
downloadgentoo-960f2f9dfd64f4685228da7f2c2ab3dd3a1efa98.tar.gz
gentoo-960f2f9dfd64f4685228da7f2c2ab3dd3a1efa98.tar.bz2
gentoo-960f2f9dfd64f4685228da7f2c2ab3dd3a1efa98.zip
dev-perl/GnuPG-Interface: add 1.40.0
Closes: https://bugs.gentoo.org/914284 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/GnuPG-Interface')
-rw-r--r--dev-perl/GnuPG-Interface/GnuPG-Interface-1.40.0.ebuild46
-rw-r--r--dev-perl/GnuPG-Interface/Manifest1
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/GnuPG-Interface/GnuPG-Interface-1.40.0.ebuild b/dev-perl/GnuPG-Interface/GnuPG-Interface-1.40.0.ebuild
new file mode 100644
index 000000000000..b1fd7aa877d1
--- /dev/null
+++ b/dev-perl/GnuPG-Interface/GnuPG-Interface-1.40.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BPS
+DIST_VERSION=1.04
+inherit perl-module
+
+DESCRIPTION="Perl interface to GnuPG"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~riscv ~x86"
+
+RDEPEND="
+ >=app-crypt/gnupg-1.4
+ virtual/perl-autodie
+ >=virtual/perl-Math-BigInt-1.780.0
+ >=dev-perl/Moo-0.91.11
+ >=dev-perl/MooX-HandlesVia-0.1.4
+ >=dev-perl/MooX-late-0.14.0
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+"
+
+PATCHES=(
+ "${FILESDIR}"/GnuPG-Interface-1.30.0-which-hunt.patch
+)
+
+src_test() {
+ # Nearly all tests succeed with this patchset and GnuPG 2.1 when running outside the
+ # emerge sandbox. However, the agent architecture is not really sandbox-friendly, so...
+ #
+ # Test Summary Report
+ # -------------------
+ # t/decrypt.t (Wstat: 0 Tests: 6 Failed: 2)
+ # Failed tests: 5-6
+ # Failed 1/22 test programs. 2/56 subtests failed.
+ #perl_rm_files t/decrypt.t
+
+ # Needs to run a setup test that spawns a persistent daemon
+ DIST_TEST="do"
+ perl-module_src_test
+}
diff --git a/dev-perl/GnuPG-Interface/Manifest b/dev-perl/GnuPG-Interface/Manifest
index edacc616ec10..f1083ff9a291 100644
--- a/dev-perl/GnuPG-Interface/Manifest
+++ b/dev-perl/GnuPG-Interface/Manifest
@@ -1 +1,2 @@
DIST GnuPG-Interface-1.03.tar.gz 77280 BLAKE2B ce22f9964fee17b8a4bd65c53b31a7ac17407fd39e4995737b0639a91538fb909f7e036faa2d23a7d6c5cdf85e56a9231b17dcaa9574aad63f1d91a49c4c1790 SHA512 5c8fb872fed755886a1f1b91bf53291207708f5dad2cbf3f69522744e9d4cee17a80cd795b91dfef7e3ce6b741cd2d0c6d8b71d109192393c5d177d781a07649
+DIST GnuPG-Interface-1.04.tar.gz 77435 BLAKE2B f72481453e07022d8bd19bfebe95ae0aa69e658288e015503be8ca2a652815c2a9c905ba361ac53c9cfda6131fcd58dd88b60d4514957b84ff0d3d2cb85dc619 SHA512 27394f08210aa1581c91640aa18006f1946098cfbe13870706cbc910de39dfa80985d265e4541cdebee70149d59c89361297f76aab0417bf904cf47ba10d1afd