summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-04 18:18:53 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-04 18:36:36 +0200
commit24155fec91083bc45ebf5dc5e97a5dd9cc782d4a (patch)
tree9f7f3a974f737130550b7c36c94e781fd41a4958 /dev-perl/MIME-Lite
parentdev-perl/MediaWiki-API: Version bump 0.52 (diff)
downloadgentoo-24155fec91083bc45ebf5dc5e97a5dd9cc782d4a.tar.gz
gentoo-24155fec91083bc45ebf5dc5e97a5dd9cc782d4a.tar.bz2
gentoo-24155fec91083bc45ebf5dc5e97a5dd9cc782d4a.zip
dev-perl/MIME-Lite: Version bump 3.033
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/MIME-Lite')
-rw-r--r--dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild45
-rw-r--r--dev-perl/MIME-Lite/Manifest1
-rw-r--r--dev-perl/MIME-Lite/files/3.033-makefilepl.patch43
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild b/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
new file mode 100644
index 000000000000..61331ec36a66
--- /dev/null
+++ b/dev-perl/MIME-Lite/MIME-Lite-3.33.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=3.033
+inherit perl-module
+
+DESCRIPTION="Low-calorie MIME generator"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="minimal"
+
+PATCHES=( "${FILESDIR}/3.033-makefilepl.patch" )
+
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
+
+# MIME::QuotedPrint -> perl-MIME-Base64
+# Mail::Address -> MailTools
+RDEPEND="
+ !minimal? (
+ virtual/perl-MIME-Base64
+ >=dev-perl/MIME-Types-1.280.0
+ >=dev-perl/MailTools-1.620.0
+ )
+ dev-perl/Email-Date-Format
+ virtual/perl-File-Spec
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# Race condition in "testout" directory creation
+DIST_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ insinto /usr/share/${PN}
+ doins -r contrib
+}
diff --git a/dev-perl/MIME-Lite/Manifest b/dev-perl/MIME-Lite/Manifest
index b0429a01c882..7e344d06a352 100644
--- a/dev-perl/MIME-Lite/Manifest
+++ b/dev-perl/MIME-Lite/Manifest
@@ -1 +1,2 @@
DIST MIME-Lite-3.030.tar.gz 81830 BLAKE2B c82fa81140725c0447fecce1f1033ed0677e1b80b6b16be7ed2567d4a71ef14fd341c367fc283242fbc4f480b48fd85859bc1660b2c12256cfe309960caf5c56 SHA512 978cb234d16afcfc9b2fa16c74de04ee74f3a1050b28f7d380d64c8c8688c6d75452d7bc4c7b2575800455a45cdde477e05e8afe2b962ef2527c3ecc265d1158
+DIST MIME-Lite-3.033.tar.gz 82715 BLAKE2B 306f641c62605559f768f45f4ceafc5267326fb475eabf45ce8e344a430117f0b335ff7939bec90343a5c23498832743de99a799d59149f26468516c4b088362 SHA512 315fbe01a432e67953305fb1db70aa337d3c7e1710087196535e108fbb516cf868a277acc693afbbc34ffa135386c6a784ddf4c1de0359fbe6c6339b26aac878
diff --git a/dev-perl/MIME-Lite/files/3.033-makefilepl.patch b/dev-perl/MIME-Lite/files/3.033-makefilepl.patch
new file mode 100644
index 000000000000..3a1c6527a74a
--- /dev/null
+++ b/dev-perl/MIME-Lite/files/3.033-makefilepl.patch
@@ -0,0 +1,43 @@
+diff -ruN MIME-Lite-3.033.orig/Makefile.PL MIME-Lite-3.033/Makefile.PL
+--- MIME-Lite-3.033.orig/Makefile.PL 2021-05-30 00:02:41.000000000 +0200
++++ MIME-Lite-3.033/Makefile.PL 2021-07-04 18:17:45.413495198 +0200
+@@ -6,39 +6,12 @@
+ #------------------------------------------------------------
+ # Makefile:
+ #------------------------------------------------------------
+-my %extra_prereq = (
+- 'Mail::Address' => 1.62,
+- 'MIME::Types' => 1.28,
+- 'MIME::Base64' => 0,
+- 'MIME::QuotedPrint' => 0,
+-);
+-
+ my %prereq = (
+ 'File::Spec' => 0,
+ 'File::Basename' => 0,
+ 'Email::Date::Format' => '1.000', # first release
+ );
+
+-for my $module (sort keys %extra_prereq) {
+- local $@;
+- my $ok = eval "require $module; \$extra_prereq{\$module} && \$module->VERSION(\$extra_prereq{\$module}); 1";
+- $prereq{ $module } = delete $extra_prereq{ $module } if $ok;
+-}
+-
+-if (%extra_prereq) {
+- print "MIME::Lite is designed to take advantage of a variety of external modules\n",
+- "if they are not present then MIME::Lite will attempt to do its best\n",
+- "but its strongly recommend that you install them.\n\n",
+- "These modules are:\n",
+- (map {; "\t$_\n" } sort keys %extra_prereq),
+- "I can add these modules to the prereq list which will cause the files to be\n",
+- "automatically installed if they aren't already present\n";
+-
+- if (prompt("Add prereqs?",'Yes')=~/y/i) {
+- %prereq = (%prereq, %extra_prereq);
+- }
+-}
+-
+ # Write the Makefile:
+ WriteMakefile(
+ NAME => 'MIME::Lite',