summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-01 18:20:35 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:29 +1300
commit61041966119c616bd7a782ca41b602c1ef2b2e51 (patch)
tree51e4d3b8114846b404c071c38f70488c88cbe7a4 /dev-perl/Mail-Sendmail
parentdev-perl/Mail-Message: Bump to version 3.2.0 (diff)
downloadgentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.tar.gz
gentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.tar.bz2
gentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.zip
dev-perl/Mail-Sendmail: Bump to version 0.800.0
- EAPI6 - Add basic compile tests - Make it possible to execute network tests Upstream: - Simplify license to Perl - Add experimental SMTP Auth - Fix bug where refused RCPT TO does global abort - send EHLO and parse response (Auth TODO) - Better handle multi-line responses - Better error messages - Normalize line endings in headers - Keep Sender header if used - Remove space after RCPT TO and MAIL FROM header Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Mail-Sendmail')
-rw-r--r--dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild50
-rw-r--r--dev-perl/Mail-Sendmail/Manifest1
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild b/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
new file mode 100644
index 000000000000..d9ca6ac0c360
--- /dev/null
+++ b/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=0.80
+inherit perl-module
+
+DESCRIPTION="Simple platform independent mailer"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Exporter
+ virtual/perl-MIME-Base64
+ virtual/perl-Socket
+ virtual/perl-Time-Local
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ local MODULES=(
+ "Mail::Sendmail ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ perl-module_src_test
+ else
+ ewarn "Network tests disabled without DIST_TEST_OVERRIDE=~network"
+ fi
+}
diff --git a/dev-perl/Mail-Sendmail/Manifest b/dev-perl/Mail-Sendmail/Manifest
index 0dfcc3fb1d69..c8094218c5cc 100644
--- a/dev-perl/Mail-Sendmail/Manifest
+++ b/dev-perl/Mail-Sendmail/Manifest
@@ -1 +1,2 @@
DIST Mail-Sendmail-0.79.tar.gz 16245 SHA256 8a5eb39d3b9a3a4219c6d6051328c62bd51e9b53723ee5b42cd66e8672e681b9 SHA512 5a39efa2f059e97b8da2d3e5f08fc30f7ac990dc7fe4f8df9580314e11c111884942335ab64af5dc4082d3a807381a8db281122237471888ecb92da6ee874e85 WHIRLPOOL 0f4ae23d70d070332347c84a726250caf63e5a7711f297c457d16b503b29920a50d9b3fe80336a363430b215c006a5e6241e4551c221d7331ec246def8f4d445
+DIST Mail-Sendmail-0.80.tar.gz 23537 SHA256 5b8a98cb5cc39d80441a38aab010885ddf80e6fcd8e6e0314392cb23e7c268e4 SHA512 848ec471938d679645dfb4e032a33d35e49655a336dc6ff3a24ffa35606bff77e73162af672d1a60ad3a7bf571113e802fc42d6cb9a072cdca0d89f707f54a08 WHIRLPOOL 9e59e46f359abd9ca5afd89ffef986de17f1a72569c0049dbac8a57049d94b55d14e478caf6aadd0d046b2f09a5c2df67a8562e3d2c7560a0bdb878439239079