summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing')
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0-r1.ebuild49
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest1
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf18
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre3
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.cron5
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh21
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml13
7 files changed, 110 insertions, 0 deletions
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0-r1.ebuild b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0-r1.ebuild
new file mode 100644
index 000000000000..0a74c69ec108
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.30.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DANBORN
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="SpamAssassin plugin to score mail based on Google blocklists"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="test"
+
+RDEPEND="dev-perl/Net-Google-SafeBrowsing-Blocklist
+ dev-perl/Net-Google-SafeBrowsing-UpdateRequest
+ mail-filter/spamassassin"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc/mail/spamassassin
+ doins "${FILESDIR}"/init_google_safebrowsing.pre
+ doins "${FILESDIR}"/24_google_safebrowsing.cf
+ insinto /etc/cron.d/
+ newins "${FILESDIR}"/update_google_safebrowsing.cron update_google_safebrowsing
+ dosbin "${FILESDIR}"/update_google_safebrowsing.sh
+ keepdir /var/lib/spamassassin/google_safebrowsing/
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/etc/cron.d/update_google_safebrowsing.sh ]]; then
+ ewarn "You MUST remove ${ROOT}/etc/cron.d/update_google_safebrowsing.sh"
+ fi
+ elog "To use this package:"
+ elog "1. You MUST apply for a free apikey at:"
+ elog " http://code.google.com/apis/safebrowsing/key_signup.html"
+ elog "2. Place the key into /etc/mail/spamassassin/24_google_safebrowsing.cf"
+ elog "3. Manually run the script /usr/sbin/update_google_safebrowsing.sh"
+ elog "4. Enable the plugin by uncommenting the loadplugin entry in"
+ elog " /etc/mail/spamassassin/init_google_safebrowsing.pre"
+ elog "5. Restart spamd"
+}
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest
new file mode 100644
index 000000000000..8117645c933c
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest
@@ -0,0 +1 @@
+DIST Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.tar.gz 4253 SHA256 39d1ddc4f539411a1c34cd96f6d0a84b4f4651c2aa08b7e596a09d4b1b718fa7 SHA512 aba284dd20d37ea502e30b9d1f2a83b3fc43749b5b2853d7fa3f651b9c406e6385d90dcaf12d8a632902aa6ffdb6ad627e4bf31a8cdd4ad850f7552d1ad7f14f WHIRLPOOL 231dbd88fca9ce61e5e6009837ed04c25454b9ce6b8d093cc12a69cf3f848ed7da1f1b32bf8f153f2d68d9f3f6256aff2b54f050bb3f599d940c23c4e283a942
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf
new file mode 100644
index 000000000000..9017753df13f
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf
@@ -0,0 +1,18 @@
+# $Id$
+ifplugin Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
+
+# Replace DEADBEEF with your API key
+# from http://code.google.com/apis/safebrowsing/key_signup.html
+google_safebrowsing_apikey DEADBEEF
+
+# Change these scores if you want
+google_safebrowsing_blocklist goog-black-hash 0.2
+google_safebrowsing_blocklist goog-malware-hash 0.1
+
+# Do not change these two lines!
+body GOOGLE_SAFEBROWSING eval:check_google_safebrowsing_blocklists()
+google_safebrowsing_dir /var/lib/spamassassin/google_safebrowsing/
+
+endif # Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
+
+# vim: ft=conf:
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre
new file mode 100644
index 000000000000..2293f00bb9e2
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre
@@ -0,0 +1,3 @@
+# $Id$
+# You need to uncomment this after you have an API key and the cronjob is active!
+#loadplugin Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.cron b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.cron
new file mode 100644
index 000000000000..bd31ef18d689
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.cron
@@ -0,0 +1,5 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+#
+*/30 * * * * root /usr/sbin/update_google_safebrowsing.sh
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh
new file mode 100644
index 000000000000..09d0d8ce3399
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+# This cron script updates the Google SafeBrowsing lists for the use of the
+# Mail-SpamAssassin-Plugin-GoogleSafeBrowsing plugin.
+# It should be run every 25-30 minutes! http://code.google.com/apis/safebrowsing/developers_guide.html#AcceptableUsage
+CONFFILE="/etc/mail/spamassassin/24_google_safebrowsing.cf"
+OUTDIR="$(awk '/^google_safebrowsing_dir/{print $2}' "${CONFFILE}")"
+APIKEY="$(awk '/^google_safebrowsing_apikey/{print $2}' "${CONFFILE}")"
+LISTS="$(awk '/^google_safebrowsing_blocklist/{printf "%s ",$2}' "${CONFFILE}")"
+if [ "$APIKEY" == "DEADBEEF" ]; then
+ echo "No API key!" 1>&2
+ exit 1
+fi
+# Wait a little while, to avoid hammering the server
+sleep $(($RANDOM % 120))
+# Use LISTS unquoted!
+for LIST in ${LISTS}; do
+ blocklist_updater --apikey "$APIKEY" --blocklist ${LIST} --dbfile ${OUTDIR}/${LIST}-db
+done
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml
new file mode 100644
index 000000000000..78d565fb8370
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Mail-SpamAssassin-Plugin-GoogleSafeBrowsing</remote-id>
+ <remote-id type="cpan-module">Mail::SpamAssassin::Plugin::GoogleSafeBrowsing</remote-id>
+ </upstream>
+</pkgmetadata>