summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-05-18 15:15:15 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-05-18 15:16:22 +0200
commit207d34034fe65eaa36f033fbb4bfbe6be4a78a46 (patch)
tree0e4f6aaabb1ef18e82250231beee7672d78fc50b /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild
parentsys-fs/btrfs-progs: Synced live ebuild. (diff)
downloadgentoo-207d34034fe65eaa36f033fbb4bfbe6be4a78a46.tar.gz
gentoo-207d34034fe65eaa36f033fbb4bfbe6be4a78a46.tar.bz2
gentoo-207d34034fe65eaa36f033fbb4bfbe6be4a78a46.zip
dev-perl/Math-BigInt-Lite: Version bump, needs perl-5.30
Closes: https://bugs.gentoo.org/686220 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild
new file mode 100644
index 000000000000..8b287fae115b
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.180.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.812
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}