summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-21 01:26:47 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-21 01:42:50 +0200
commit7b31d3a74d0dadde2897b0179ecbf3dd3f795c8e (patch)
treed4d40e60ff2a5945d330c67a177a7342757fd0c6 /dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild
parentdev-perl/OOTools: Version bump 2.41 (diff)
downloadgentoo-7b31d3a74d0dadde2897b0179ecbf3dd3f795c8e.tar.gz
gentoo-7b31d3a74d0dadde2897b0179ecbf3dd3f795c8e.tar.bz2
gentoo-7b31d3a74d0dadde2897b0179ecbf3dd3f795c8e.zip
dev-perl/OpenGL: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild')
-rw-r--r--dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild b/dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild
new file mode 100644
index 000000000000..e1ebf307e286
--- /dev/null
+++ b/dev-perl/OpenGL/OpenGL-0.700.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CHM
+DIST_VERSION=0.70
+
+inherit perl-module
+
+DESCRIPTION="Perl interface providing graphics display using OpenGL"
+
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ media-libs/freeglut:0=
+ x11-libs/libICE:0=
+ x11-libs/libXext:0=
+ x11-libs/libXi:0=
+ x11-libs/libXmu:0=
+"
+DEPEND="${RDEPEND}
+"
+BDEPEND="${RDEPEND}
+"
+
+mydoc="Release_Notes"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-no-display.patch
+ # This should be merely moved to t/ as it gets
+ # installed to OS otherwise.
+ # But it presently fails tests, and can't be made not to.
+ # ( And will need virtualx when it can )
+ # Something to do with OpenGL implementation ala eselect.
+ perl_rm_files "test.pl";
+ perl-module_src_prepare
+}
+
+src_compile() {
+ sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
+ perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}