summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-04 22:38:56 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-08 01:07:41 +0200
commit2c115895091f4dfee5b867b5fdec25419c36a85b (patch)
treefb09fc5e4d1665dccd993d7d3ad432c877769cdb /dev-perl/Pod-Spell
parentdev-perl/File-ShareDir-ProjectDistDir: Added to tree at 1.0.8 (diff)
downloadgentoo-2c115895091f4dfee5b867b5fdec25419c36a85b.tar.gz
gentoo-2c115895091f4dfee5b867b5fdec25419c36a85b.tar.bz2
gentoo-2c115895091f4dfee5b867b5fdec25419c36a85b.zip
dev-perl/Pod-Spell: Bump to version 1.190.0
- EAPI6 - Lots of extra deps Upstream: - Automatic Plural inclusion added - OO Interface added for wordlists - 's stopwords now processed without 's - Punctuation stripped from words - added an option to strip words with utf8 characters - Output encoding defaults to CTYPE Keywording: New deps, lost: alpha ppc ppc64 sparc Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Pod-Spell')
-rw-r--r--dev-perl/Pod-Spell/Manifest1
-rw-r--r--dev-perl/Pod-Spell/Pod-Spell-1.190.0.ebuild44
-rw-r--r--dev-perl/Pod-Spell/metadata.xml2
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Pod-Spell/Manifest b/dev-perl/Pod-Spell/Manifest
index 052de61a762a..f18213ad7bf9 100644
--- a/dev-perl/Pod-Spell/Manifest
+++ b/dev-perl/Pod-Spell/Manifest
@@ -1,2 +1,3 @@
DIST Pod-Spell-1.01.tar.gz 12846 SHA256 938648dca5b62e591783347f9d4d4e2a5239f9629c6adfed9a581b9457ef7d2e SHA512 d846ff32a7129ff47aa8b90a9857fc2258eee5ce74ee158fa142e463592ed2d45d589fb378f1d3e17aa67adedd0059951c39d7d87dd367157c11c9c99fc49f71 WHIRLPOOL 9628caf621bf4513252c58b88383801d29a1262c9b4ef5de5f900cd7a86f696bac1ea88738613cc5203f6d1af95c68ed1001c76fbf6a6de61872a53d80836aea
+DIST Pod-Spell-1.19.tar.gz 29244 SHA256 6d8bb05578dab2c62f50442802e25baecc9ae844ab40773a346aab565ba6654d SHA512 d9be19a67558d1d6e5c42f50df963ff3b2168f5cf78d25d7415c4fef92d5c6dfa0d0db0621d58358ea438efb50542652febaf8d18a7e3c16e79412bf8ae09999 WHIRLPOOL 475e761813c062473564633a895c8e8430580840f783f6f0b6e80d17faf6f6dbb458ca8b191287429728e9eb3e90361e08d02f719d120e91ba1204d61b79dc90
DIST podspell.1.gz 648 SHA256 9d820c0cc34986de050e7cf4634e09d5fddb0c3b7db2b76c704edb22b350bee1 SHA512 651d2fc9376329cb95986a885119dfd542f55e79045ec7aa2f37afcd9fc7bd86ba690c2e3a247b35ffd2d90c9adc9ad85e2d6128fb3424c75130d70aacb1c154 WHIRLPOOL 9d9a8f9d8cc4988a831553443d69128cefc5d36999543261442a28edda4b45ad455138ba41e4b15b0f1e9063ed33cfedf5f2b9afce2cc1ae0da54a73e04bb30b
diff --git a/dev-perl/Pod-Spell/Pod-Spell-1.190.0.ebuild b/dev-perl/Pod-Spell/Pod-Spell-1.190.0.ebuild
new file mode 100644
index 000000000000..dc563d7c9b1f
--- /dev/null
+++ b/dev-perl/Pod-Spell/Pod-Spell-1.190.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DOLMEN
+DIST_VERSION=1.19
+inherit perl-module
+
+DESCRIPTION="A formatter for spellchecking Pod"
+SRC_URI+=" mirror://gentoo/podspell.1.gz https://dev.gentoo.org/~tove/files/podspell.1.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Tiny
+ >=dev-perl/File-ShareDir-ProjectDistDir-1.0.0
+ dev-perl/Lingua-EN-Inflect
+ virtual/perl-Pod-Escapes
+ virtual/perl-Pod-Parser
+ virtual/perl-Text-Tabs+Wrap
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.60.0
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ dev-perl/Test-Deep
+ virtual/perl-Test-Simple
+ )
+"
+
+src_install() {
+ perl-module_src_install
+ doman "${WORKDIR}"/podspell.1 || die
+}
diff --git a/dev-perl/Pod-Spell/metadata.xml b/dev-perl/Pod-Spell/metadata.xml
index 99d40655c8c7..c00665b9f463 100644
--- a/dev-perl/Pod-Spell/metadata.xml
+++ b/dev-perl/Pod-Spell/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="cpan">Pod-Spell</remote-id>
+ <remote-id type="cpan-module">Pod::Spell</remote-id>
+ <remote-id type="cpan-module">Pod::Wordlist</remote-id>
</upstream>
</pkgmetadata>