summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Server-Starter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Server-Starter')
-rw-r--r--dev-perl/Server-Starter/Manifest2
-rw-r--r--dev-perl/Server-Starter/Server-Starter-0.120.0-r1.ebuild30
-rw-r--r--dev-perl/Server-Starter/Server-Starter-0.190.0.ebuild30
-rw-r--r--dev-perl/Server-Starter/metadata.xml9
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Server-Starter/Manifest b/dev-perl/Server-Starter/Manifest
new file mode 100644
index 000000000000..8a1a836ae20e
--- /dev/null
+++ b/dev-perl/Server-Starter/Manifest
@@ -0,0 +1,2 @@
+DIST Server-Starter-0.12.tar.gz 32104 SHA256 ee4d0abcd3bce51e2d32375b9ab3b57dfd17d9289281af2d811f0b54af892dc6 SHA512 23469976ad1d9f2e1180818cd45e4189fa569f30c56628f98542b5d10f531ef56929461dfab3cbf9a6ba4a493b642f0cc8d6e2418825f33f1111c2633afc19f0 WHIRLPOOL c7ec52e213ebc3f8b6fd5cef671c7cebc25ec29d17d495bcb105d4e50b57d549db833cf83e8017e99ca514aa3c2f0a3a07a3ac4df9fcfe3782bc0d49857f10a1
+DIST Server-Starter-0.19.tar.gz 36943 SHA256 ac11bf46867479ba997ef6396da59735c988a0fc0a54b84980cf03d65b9d5651 SHA512 ebd212cc1fd6ae09b3a6517f1a8490a494a44173c7fcc1f45215e4dd4f5e079c4326b66c66614ada3187365eea760cd7954e1e7df394cb1162ebdabda6daff3d WHIRLPOOL bfcc710d505daf4dda0829179baea47553052eda9dec497dd1adec5e6e757acbe269a0b70a2e57b0539287b52a4f1eafac541aff96baf990c2729b61cb39a871
diff --git a/dev-perl/Server-Starter/Server-Starter-0.120.0-r1.ebuild b/dev-perl/Server-Starter/Server-Starter-0.120.0-r1.ebuild
new file mode 100644
index 000000000000..9b27483ad3f0
--- /dev/null
+++ b/dev-perl/Server-Starter/Server-Starter-0.120.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=KAZUHO
+MODULE_VERSION=0.12
+inherit perl-module
+
+DESCRIPTION="A superdaemon for hot-deploying server programs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Getopt-Long
+ dev-perl/List-MoreUtils
+ dev-perl/Proc-Wait3
+ dev-perl/Scope-Guard
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-SharedFork
+ >=dev-perl/Test-TCP-0.110.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Server-Starter/Server-Starter-0.190.0.ebuild b/dev-perl/Server-Starter/Server-Starter-0.190.0.ebuild
new file mode 100644
index 000000000000..cf48619f2e05
--- /dev/null
+++ b/dev-perl/Server-Starter/Server-Starter-0.190.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=KAZUHO
+MODULE_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="A superdaemon for hot-deploying server programs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Getopt-Long
+ dev-perl/List-MoreUtils
+ dev-perl/Proc-Wait3
+ dev-perl/Scope-Guard
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-SharedFork
+ >=dev-perl/Test-TCP-0.110.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Server-Starter/metadata.xml b/dev-perl/Server-Starter/metadata.xml
new file mode 100644
index 000000000000..8eb6deb5353f
--- /dev/null
+++ b/dev-perl/Server-Starter/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Server-Starter</remote-id>
+ <remote-id type="cpan-module">Server::Starter</remote-id>
+ </upstream>
+</pkgmetadata>