summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-11 06:06:42 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-11 06:14:52 +1300
commitd06bd63a90784e328f25fdb065e1dfed735541ca (patch)
tree1599c803957486e64def0b056ceed111d04507b3 /dev-perl/Sys-Virt
parentnet-misc/bfgminer: add alchemist to REQUIRED_USE for scrypt (diff)
downloadgentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.tar.gz
gentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.tar.bz2
gentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.zip
dev-perl/Sys-Virt: Bump to version 3.9.1
Upstream: - Fix '.' in @INC - New constants: LIST_CAP_MDEV, LIST_CAP_MDEV_TYPES, RECV_STOP_AT_HOLE VOL_DOWNLOAD_SPARSE_STREAM, VOL_UPLOAD_SPARSE_STREAM, LIST_CAP_CCWD_DEV, VIR_DOMAIN_BLOCK_COPY_TRANSIENT_JOB, VIR_FROM_RESCTRL, VIR_STORAGE_POOL_EVENT_{DELETED,CREATED}, VIR_DOMAIN_JOB_MEMORY_PAGE_SIZE and domain event constants - Fix send_all() callback helper - Introduce flags to Stream::recv - Add methods: Stream::{{recv,send}_hole,sparce_{recv,send}_all}, migrate_get_max_downtime, managed_save_define_xml, managed_save_get_xml_description, set_lifecycle_action - Add vol-sparse.pl example - Fix package location of lifecycle constants Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Sys-Virt')
-rw-r--r--dev-perl/Sys-Virt/Manifest1
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Manifest b/dev-perl/Sys-Virt/Manifest
index ef3aa3b73167..4b0c2fca575c 100644
--- a/dev-perl/Sys-Virt/Manifest
+++ b/dev-perl/Sys-Virt/Manifest
@@ -5,3 +5,4 @@ DIST Sys-Virt-2.4.0.tar.gz 115304 BLAKE2B 9f0f685c8f22f74dfa6cf0745e48130351bb7c
DIST Sys-Virt-2.5.0.tar.gz 115397 BLAKE2B 21c1f131e17db37f91373a7273c8a1da1bd3172be69ea6c32ec54ac126513ce84335646db7e4482943c7d42da820676e0ac17f229606afcf6b96281029ffb969 SHA512 078ab8a33090fd12eda8615973a871e0a6c6c781bc958e94e86c7cd0bd3b3ab6204aa9b884b58c87907ff9c9f311e998cc9c54e0dec63d7f5670eccc15f30741
DIST Sys-Virt-3.1.0.tar.gz 116732 BLAKE2B 567e6a696ad1a07f78c9426e3da0c7737bafa0e95ffdb8106bae998de3565d726541aff8789ca7c65b4dafa007d2d6dd2e8b73f4449b39b59f82d90b228051fc SHA512 897b8a33aed48e836650bf24073fc7ab1ad406ab2fcb43809b8756d46cd2e20b99cd93ea7e7307cf39f6260ffc2f8053a531964472e875f5c3415a3304e0d3be
DIST Sys-Virt-3.3.0.tar.gz 117971 BLAKE2B c3b14c8a47e8691af89ba07efa41bc4d03fbfccb526b9585dd9b53385de82ee8844cddb5f6abe8b842889db55a5d10df1f34d55068f00f86004a4c57246a7bf7 SHA512 d1255213c4d902f3330f2eb5a8b9df790c4af9036cb68686cf0e94483dd3e00f4b173968065cdd15305452f5a85e3f5affa432ef9042af8d9442b82ccc4db2ab
+DIST Sys-Virt-3.9.1.tar.gz 121473 BLAKE2B 8cd9211c4182a296da54a26db8007312ab1ed5e5151ea91bcdd5e104610671c8e81e3e8526c97d9f22b8a83151a167703438341ad73db6e91fd57450fb6f3de4 SHA512 baff550548ca7a477643998fd1da20963acb00a9ac300b63a01c60639e971f55aa4e4616a916373dde3e05956237a122b85e2f32f9ea2fab63a7ec72e45819b2
diff --git a/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild b/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild
new file mode 100644
index 000000000000..024ad6bd89fe
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANBERR
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
+ perl-module_src_test
+}