summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-13 20:57:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-13 21:16:54 +0200
commitc91499a675595be7ff8775beece8b780ef44b3d6 (patch)
tree0b4a8db84e38be6d4eaa31faf80f580b414021a7 /dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild
parentdev-perl/Template-GD: EAPI=8 bump (diff)
downloadgentoo-c91499a675595be7ff8775beece8b780ef44b3d6.tar.gz
gentoo-c91499a675595be7ff8775beece8b780ef44b3d6.tar.bz2
gentoo-c91499a675595be7ff8775beece8b780ef44b3d6.zip
dev-perl/Template-Plugin-Cycle: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild')
-rw-r--r--dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild
new file mode 100644
index 000000000000..5e6ec6d66557
--- /dev/null
+++ b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.06
+
+inherit perl-module
+
+DESCRIPTION="Cyclically insert into a Template from a sequence of values"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-perl/Params-Util-1.60.0
+ >=dev-perl/Template-Toolkit-2.240.0
+"
+BDEPEND="${RDEPEND}
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}