summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 11:56:35 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 11:57:46 +1200
commitdb9ce478417dad2a495847e03b311487f42d52b9 (patch)
tree8f09a0a5ba623938f47d96233a9b32acf0c5df53 /dev-perl/autovivification
parentdev-perl/autobox: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-db9ce478417dad2a495847e03b311487f42d52b9.tar.gz
gentoo-db9ce478417dad2a495847e03b311487f42d52b9.tar.bz2
gentoo-db9ce478417dad2a495847e03b311487f42d52b9.zip
dev-perl/autovivification: -r bump for EAPI + CFLAGS love
- EAPI7 - Ensure CFLAGS passed through make/complier Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/autovivification')
-rw-r--r--dev-perl/autovivification/autovivification-0.180.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/autovivification/autovivification-0.180.0-r1.ebuild b/dev-perl/autovivification/autovivification-0.180.0-r1.ebuild
new file mode 100644
index 000000000000..fe741a705893
--- /dev/null
+++ b/dev-perl/autovivification/autovivification-0.180.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=VPIT
+DIST_VERSION=0.18
+DIST_EXAMPLES=("samples/*")
+inherit perl-module
+
+DESCRIPTION="Lexically disable autovivification"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/perl-XSLoader"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}