summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-16 06:46:53 +0100
committerSam James <sam@gentoo.org>2021-10-16 06:46:53 +0100
commit6ecb2628b95c308346cc6a196f8f95d8e295ecb5 (patch)
treecdecbcf1bd04bc514b673be224459db2e3cff73a /dev-perl
parentdev-python/python-levenshtein: Stabilize 0.12.2 sparc, #818361 (diff)
downloadgentoo-6ecb2628b95c308346cc6a196f8f95d8e295ecb5.tar.gz
gentoo-6ecb2628b95c308346cc6a196f8f95d8e295ecb5.tar.bz2
gentoo-6ecb2628b95c308346cc6a196f8f95d8e295ecb5.zip
dev-perl/Gtk2: skip broken/irrelevant GdkPixbuf test
Closes: https://bugs.gentoo.org/774396 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Gtk2/Gtk2-1.249.930.ebuild4
-rw-r--r--dev-perl/Gtk2/files/Gtk2-1.249.930-skip-pixbuf-test.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Gtk2/Gtk2-1.249.930.ebuild b/dev-perl/Gtk2/Gtk2-1.249.930.ebuild
index 96a0c9b312cf..051e156e4210 100644
--- a/dev-perl/Gtk2/Gtk2-1.249.930.ebuild
+++ b/dev-perl/Gtk2/Gtk2-1.249.930.ebuild
@@ -32,6 +32,10 @@ BDEPEND="${RDEPEND}
test? ( x11-libs/gdk-pixbuf[jpeg] )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.249.930-skip-pixbuf-test.patch
+)
+
src_test() {
virtx perl-module_src_test
}
diff --git a/dev-perl/Gtk2/files/Gtk2-1.249.930-skip-pixbuf-test.patch b/dev-perl/Gtk2/files/Gtk2-1.249.930-skip-pixbuf-test.patch
new file mode 100644
index 000000000000..b64d9470a48e
--- /dev/null
+++ b/dev-perl/Gtk2/files/Gtk2-1.249.930-skip-pixbuf-test.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/774396
+https://git.launchpad.net/ubuntu/+source/libgtk2-perl/tree/debian/patches/new_gdk_pixbuf.patch
+
+# Description: skip a test that is made invalid by the new gdk-pixbuf
+# Upstream: https://gitlab.gnome.org/GNOME/perl-gtk2/issues/3
+#
+--- a/t/GdkPixbuf.t
++++ b/t/GdkPixbuf.t
+@@ -123,9 +123,12 @@ my $log = Glib::Log->set_handler ('GdkPi
+ $pixbuf = Gtk2::Gdk::Pixbuf->new_from_xpm_data (@test_xpm[0..2]);
+ ok (! defined ($pixbuf), "Don't crash on broken pixmap data");
+ $pixbuf = Gtk2::Gdk::Pixbuf->new_from_xpm_data (@test_xpm[0..5]);
+-ok (defined $pixbuf, "Don't crash on partial pixmap data");
+-Glib::Log->remove_handler ('GdkPixbuf', $log);
+-
++SKIP: {
++ skip 'new gdk-pixbuf error out on invalid xpm', 1;
++
++ ok (defined $pixbuf, "Don't crash on partial pixmap data");
++ Glib::Log->remove_handler ('GdkPixbuf', $log);
++}
+
+ # raw pixel values to make the xpm above
+ my $rawdata = pack 'C*',