summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-21 04:06:23 +0000
committerSam James <sam@gentoo.org>2023-01-21 04:06:23 +0000
commitb6298932089618c5df75fdc5c86929c7e169df35 (patch)
tree122a72ef98fcc7469ecbbdced68b30f799d71a6e /dev-perl
parentx11-libs/pixman: fix build for arm64 (diff)
downloadgentoo-b6298932089618c5df75fdc5c86929c7e169df35.tar.gz
gentoo-b6298932089618c5df75fdc5c86929c7e169df35.tar.bz2
gentoo-b6298932089618c5df75fdc5c86929c7e169df35.zip
dev-perl/Digest-Nilsimsa: fix build w/ clang 16
Closes: https://bugs.gentoo.org/870895 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r4.ebuild (renamed from dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r3.ebuild)6
-rw-r--r--dev-perl/Digest-Nilsimsa/files/Digest-Nilsimsa-0.60.0-clang16.patch19
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r3.ebuild b/dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r4.ebuild
index eb631b859acd..ba2130110c56 100644
--- a/dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r3.ebuild
+++ b/dev-perl/Digest-Nilsimsa/Digest-Nilsimsa-0.60.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,10 @@ LICENSE="GPL-2+ LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.60.0-clang16.patch
+)
+
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
diff --git a/dev-perl/Digest-Nilsimsa/files/Digest-Nilsimsa-0.60.0-clang16.patch b/dev-perl/Digest-Nilsimsa/files/Digest-Nilsimsa-0.60.0-clang16.patch
new file mode 100644
index 000000000000..f8c7cd6b57c1
--- /dev/null
+++ b/dev-perl/Digest-Nilsimsa/files/Digest-Nilsimsa-0.60.0-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870895
+https://rt.cpan.org/Public/Bug/Display.html?id=145874
+
+Add missing function prototypes. This avoids implicit function
+declarations when building Nilsimsa.xs and build failures with future
+compilers.
+
+--- a/nilsimsa.h
++++ b/nilsimsa.h
+@@ -47,6 +47,8 @@ int nilsimsa(struct nsrecord *a,struct nsrecord *b);
+ void aggregate(int n);
+ void codetostr(struct nsrecord *a,char *str);
+ int strtocode(char *str,struct nsrecord *a);
++void makecode(struct nsrecord *a);
++void clear(struct nsrecord *a);
+
+ int accbuf(unsigned char *buf,int len,struct nsrecord *a);
+ void dprint(char *msg);
+