summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-php/PEAR-Text_Wiki
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Text_Wiki')
-rw-r--r--dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild3
-rw-r--r--dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.3.ebuild1
2 files changed, 3 insertions, 1 deletions
diff --git a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
index 0432d3039885..af6715552fb2 100644
--- a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
+++ b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,6 +10,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
# Pull from github as pear.php.net is not updated
SRC_URI="https://github.com/pear/${PHP_PEAR_PKG_NAME}/archive/32fd5f483f34645f4efd96d385d8950ea26d4a2a.tar.gz -> ${PEAR_P}.tar.gz"
diff --git a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.3.ebuild b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.3.ebuild
index 3eaca2e83436..71ce9d98ae0f 100644
--- a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.3.ebuild
+++ b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.3.ebuild
@@ -10,6 +10,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-php/phpunit dev-php/PEAR-PEAR )"