summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-dio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-dio')
-rw-r--r--dev-php/pecl-dio/Manifest1
-rw-r--r--dev-php/pecl-dio/metadata.xml5
-rw-r--r--dev-php/pecl-dio/pecl-dio-0.0.7-r1.ebuild29
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-dio/Manifest b/dev-php/pecl-dio/Manifest
new file mode 100644
index 000000000000..32bc793ecd1c
--- /dev/null
+++ b/dev-php/pecl-dio/Manifest
@@ -0,0 +1 @@
+DIST dio-0.0.7.tgz 19570 SHA256 0294c0f88705213b30589c565fffa1a3e7cb036806eaa2a47e6a793914a821fe SHA512 00925d6f6640f6a17c5bb8997910f15978c9e53b190ff4a44c3a23138013d1f460ef6fa1522fd5f5b1bd51130b859ea1619beffdb702a69b99a13e5eadd8ca25 WHIRLPOOL 4511273497f32ae726cce8153a83bca31b529e21dd73b1330cab9a8d56fc42fa993ae699631989f12625a25e4aa3aad9a25a036c86894a35c6f61c9c620ba037
diff --git a/dev-php/pecl-dio/metadata.xml b/dev-php/pecl-dio/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/pecl-dio/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-dio/pecl-dio-0.0.7-r1.ebuild b/dev-php/pecl-dio/pecl-dio-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..d4d4865cead8
--- /dev/null
+++ b/dev-php/pecl-dio/pecl-dio-0.0.7-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="dio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+MY_PV=${PV/_rc/RC}
+S="${WORKDIR}/${PN/pecl-/}-${MY_PV}"
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Direct I/O functions for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+src_configure() {
+ my_conf="--enable-dio --enable-shared"
+
+ php-ext-source-r2_src_configure
+}