summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:06:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:33:00 +0200
commit22e135eb4ed9f1e902c677501e2f6003f57e5f58 (patch)
tree54d06eb5bd9c3bc287fbd9d19582c706e9f29c93 /dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild
parentdev-php/pecl-uploadprogress: bump to v2.0.2 (diff)
downloadgentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.tar.gz
gentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.tar.bz2
gentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.zip
dev-php/pecl-rrd: bump to v2.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild')
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild
new file mode 100644
index 000000000000..034811552435
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-analyzer/rrdtool[graph(-)]"
+RDEPEND="${DEPEND}"
+
+#PATCHES=( "${FILESDIR}/${PV}" )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Prepare test data
+ emake -C tests/data all
+ NO_INTERACTION="yes" emake test
+ done
+}