summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:13:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:33:02 +0200
commita54eff9b7bbdd87428e864bb77127ffc83a2604e (patch)
treeff21f2847f999cf75f42bd17a74f1223a803357d /dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
parentdev-php/PHP_CodeSniffer: bump to v3.6.1 (diff)
downloadgentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.tar.gz
gentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.tar.bz2
gentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.zip
dev-php/phar-io-manifest: bump to v2.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild')
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
new file mode 100644
index 000000000000..25f65d07e8d4
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="https://github.com/phar-io/manifest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-php/phar-io-version-3.0.1
+ >=dev-lang/php-7.2:*[phar,xml(-),xmlwriter(-)]"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/manifest-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+
+ cat >> src/autoload.php <<EOF || die "failed to extend autoload.php"
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PharIo/Version/autoload.php'
+]);
+EOF
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ dodoc README.md
+ use examples && dodoc -r examples
+}