summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-07-27 14:35:54 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-07-27 14:48:38 -0400
commit219e14c37dacd126d7a108ee73ef12a1db8e3327 (patch)
tree58da5befec19f3cbc70a4d5cce12c4669b39ace7 /dev-php
parentdev-php/pecl-http: drop 3.2.4-r1, 3.2.5, 4.2.1 (diff)
downloadgentoo-219e14c37dacd126d7a108ee73ef12a1db8e3327.tar.gz
gentoo-219e14c37dacd126d7a108ee73ef12a1db8e3327.tar.bz2
gentoo-219e14c37dacd126d7a108ee73ef12a1db8e3327.zip
dev-php/swoole: drop 4.4.16, 4.5.9
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/Manifest2
-rw-r--r--dev-php/swoole/swoole-4.4.16.ebuild67
-rw-r--r--dev-php/swoole/swoole-4.5.9.ebuild67
3 files changed, 0 insertions, 136 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index a44e9a230a1e..f83ffe54f33e 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -1,3 +1 @@
-DIST swoole-4.4.16.tgz 1457270 BLAKE2B 4b65270aa1014ea68cadae8eb021d37498dc3fe0bf2d681c95bf7113928138bc26ab73f3be91185eb5ecebcb4940906814913c7908c87592aafd33fbc1820bf7 SHA512 7be4705967ed6b7a955f679f8c39585d34dc8c87ba608ac3ae2b0fc3cae9513d9639c8e9aac4278ce85acc215b500044626aab9b2aac725c9ffaef72dfb02dd7
-DIST swoole-4.5.9.tgz 1552445 BLAKE2B 602ce65f7b59a3c199d7718aeb941d1ebde7d59096335992c2278f7e330f7b48554a8418cc4014f6fcf47af92d315368a16c572055b1fd9575608c2559ed3107 SHA512 9154a2874480218aa3c8935979267efb92a3d5a4f1ba7dc071bf4c2b169d69e31a6ad7412785d00543dc5827ce2d6c5999b6cabea2089818f3f57acc26bcb31f
DIST swoole-4.8.7.tgz 1851160 BLAKE2B 3e5c9d664f1897b7bd490a1e9dbc4c3c03117a18ae58586efe534c617578a7af5be779e6ca44a5bf2f782abc2eb57bc21e3dc4e3445c3299918bc189547dc75c SHA512 36f36aface71435233aaa8c81e023b813c6175d3ed00a9de20acb690b58b464d99670c3b96f247ab1147f95e099d44785d60d5f1e36f519ccfeb09b3bddba264
diff --git a/dev-php/swoole/swoole-4.4.16.ebuild b/dev-php/swoole/swoole-4.4.16.ebuild
deleted file mode 100644
index 5df2ebd4942d..000000000000
--- a/dev-php/swoole/swoole-4.4.16.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="swoole"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_SAPIS="cli"
-DOCS=( README.md )
-
-USE_PHP="php7-4"
-
-inherit php-ext-pecl-r3
-
-HOMEPAGE="https://www.swoole.co.uk"
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests can hang. Disable until this no longer happens
-RESTRICT="test"
-
-DEPEND="
- app-arch/brotli:0=
- dev-libs/libaio
- dev-libs/boost:=
- dev-libs/libpcre
- sys-libs/zlib:0=
- http2? ( net-libs/nghttp2:0= )
- ssl? (
- dev-libs/openssl:0=
- )
- php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
- mysql? (
- php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
- )
-"
-
-RDEPEND="${DEPEND}"
-
-IUSE="debug http2 mysql sockets ssl"
-
-src_configure() {
- # JEMalloc not included as it refuses to find a ${ESYSROOT}/usr/includes/jemalloc subdirectory
- local PHP_EXT_ECONF_ARGS=(
- --enable-swoole
- $(use_enable debug)
- $(use_enable http2)
- $(use_enable mysql mysqlnd)
- $(use_enable ssl openssl)
- $(use_with ssl openssl-dir "${ESYSROOT}/usr")
- $(use_enable sockets)
- )
-
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- [[ -f tests/template.phpt ]] && rm tests/template.phpt
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}
diff --git a/dev-php/swoole/swoole-4.5.9.ebuild b/dev-php/swoole/swoole-4.5.9.ebuild
deleted file mode 100644
index 5c0345cb8a3e..000000000000
--- a/dev-php/swoole/swoole-4.5.9.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="swoole"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_SAPIS="cli"
-PHP_EXT_NEEDED_USE="cli,sockets?"
-DOCS=( README.md )
-
-USE_PHP="php7-2 php7-3 php7-4 php8-0"
-
-inherit php-ext-pecl-r3
-
-HOMEPAGE="https://www.swoole.co.uk"
-KEYWORDS="amd64 ~x86"
-
-DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests can hang. Disable until this no longer happens
-RESTRICT="test"
-
-DEPEND="
- app-arch/brotli:0=
- dev-libs/libpcre
- sys-libs/zlib:0=
- ssl? (
- dev-libs/openssl:0=
- )
- mysql? (
- php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
- php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
- php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
- php_targets_php8-0? ( dev-lang/php:8.0[mysql,mysqli(+)] )
- )
-"
-
-RDEPEND="${DEPEND}"
-
-IUSE="debug http2 mysql sockets ssl"
-
-src_configure() {
- # JEMalloc not included as it refuses to find a ${ESYSROOT}/usr/includes/jemalloc subdirectory
- local PHP_EXT_ECONF_ARGS=(
- --enable-swoole
- $(use_enable debug)
- $(use_enable http2)
- $(use_enable mysql mysqlnd)
- $(use_enable ssl openssl)
- $(use_with ssl openssl-dir "${ESYSROOT}/usr")
- $(use_enable sockets)
- )
-
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- [[ -f tests/template.phpt ]] && rm tests/template.phpt
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}