summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 20:36:12 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 21:43:38 +0300
commit2901bcf632742b711d1c06eb7c76450f01debb8c (patch)
tree6cdad40aa1b789fdee74e2aa2b162d78c0c5b04d /dev-php
parentdev-php/PEAR-Pager: treeclean (diff)
downloadgentoo-2901bcf632742b711d1c06eb7c76450f01debb8c.tar.gz
gentoo-2901bcf632742b711d1c06eb7c76450f01debb8c.tar.bz2
gentoo-2901bcf632742b711d1c06eb7c76450f01debb8c.zip
dev-php/PEAR-Services_JSON: treeclean
Bug: https://bugs.gentoo.org/933998 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Services_JSON/Manifest1
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild19
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch42
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch20
-rw-r--r--dev-php/PEAR-Services_JSON/metadata.xml8
5 files changed, 0 insertions, 90 deletions
diff --git a/dev-php/PEAR-Services_JSON/Manifest b/dev-php/PEAR-Services_JSON/Manifest
deleted file mode 100644
index 9b6ab90d9430..000000000000
--- a/dev-php/PEAR-Services_JSON/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Services_JSON-1.0.3.tgz 9529 BLAKE2B 5a35899d53b66f3534afd64105c361e7aafa22641f540ef5ed38789ccc771f4e62577b1044af8d617579aed36e014e38e6bc30f39b476b09b47202d8822028d7 SHA512 2a94bebb662e250d56ae1f02f6debbff9e956820a603b8c4520f48ad0ed67a40c342d4eb000be9a9cf0e5b91c7bf9ebf98fae87f9ecca217b94b12441b746e5e
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
deleted file mode 100644
index d3d89067cc4c..000000000000
--- a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2
-
-IUSE=""
-DESCRIPTION="PHP implementaion of json_encode/decode"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
-PATCHES=( "${FILESDIR}/JSON-1.0.3-upstream-typo.patch" "${FILESDIR}/JSON-1.0.3-constructor.patch" )
-
-src_install() {
- php-pear-r2_src_install
- insinto /usr/share/php/Services
- doins JSON.php
-}
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
deleted file mode 100644
index d7348f0f858e..000000000000
--- a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -aurN a/JSON.php b/JSON.php
---- a/JSON.php 2011-01-13 21:40:48.000000000 -0500
-+++ b/JSON.php 2018-02-15 11:42:06.551287857 -0500
-@@ -139,6 +139,14 @@
- * strings or numbers, if you return an object, make sure it does
- * not have a toJSON method, otherwise an error will occur.
- */
-+ function __construct($use = 0)
-+ {
-+ $this->use = $use;
-+ $this->_mb_strlen = function_exists('mb_strlen');
-+ $this->_mb_convert_encoding = function_exists('mb_convert_encoding');
-+ $this->_mb_substr = function_exists('mb_substr');
-+ }
-+
- function Services_JSON($use = 0)
- {
- $this->use = $use;
-@@ -909,6 +917,11 @@
-
- class Services_JSON_Error extends PEAR_Error
- {
-+ function __construct($message = 'unknown error', $code = null,
-+ $mode = null, $options = null, $userinfo = null)
-+ {
-+ parent::__construct($message, $code, $mode, $options, $userinfo);
-+ }
- function Services_JSON_Error($message = 'unknown error', $code = null,
- $mode = null, $options = null, $userinfo = null)
- {
-@@ -923,6 +936,11 @@
- */
- class Services_JSON_Error
- {
-+ function __construct($message = 'unknown error', $code = null,
-+ $mode = null, $options = null, $userinfo = null)
-+ {
-+ return;
-+ }
- function Services_JSON_Error($message = 'unknown error', $code = null,
- $mode = null, $options = null, $userinfo = null)
- {
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
deleted file mode 100644
index c7d8be3aa910..000000000000
--- a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/JSON.php 2011/01/28 00:16:42 307804
-+++ b/JSON.php 2013/04/30 02:37:26 330165
-@@ -554,7 +544,7 @@
-
- return ($this->use & SERVICES_JSON_SUPPRESS_ERRORS)
- ? 'null'
-- : new Services_JSON_Error(class_name($var).
-+ : new Services_JSON_Error(get_class($var).
- " toJSON returned an object with a toJSON method.");
-
- }
-@@ -995,7 +985,7 @@
- function Services_JSON_Error($message = 'unknown error', $code = null,
- $mode = null, $options = null, $userinfo = null)
- {
--
-+ return;
- }
- }
-
diff --git a/dev-php/PEAR-Services_JSON/metadata.xml b/dev-php/PEAR-Services_JSON/metadata.xml
deleted file mode 100644
index 77793b997e9e..000000000000
--- a/dev-php/PEAR-Services_JSON/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
-</pkgmetadata>