summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 15:55:02 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:21 +0200
commitf05d38336184a8e75658bd000a6a51b3c205c31f (patch)
tree9cce483f3abc6eb4f2c361deed6b42461b288b73 /dev-python/PyContracts
parentdev-python/pbr: Add python3.5 (diff)
downloadgentoo-f05d38336184a8e75658bd000a6a51b3c205c31f.tar.gz
gentoo-f05d38336184a8e75658bd000a6a51b3c205c31f.tar.bz2
gentoo-f05d38336184a8e75658bd000a6a51b3c205c31f.zip
dev-python/PyContracts: New package, ebuild written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/PyContracts')
-rw-r--r--dev-python/PyContracts/Manifest1
-rw-r--r--dev-python/PyContracts/PyContracts-1.7.6.ebuild37
-rw-r--r--dev-python/PyContracts/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/PyContracts/Manifest b/dev-python/PyContracts/Manifest
new file mode 100644
index 000000000000..8a008adf64ab
--- /dev/null
+++ b/dev-python/PyContracts/Manifest
@@ -0,0 +1 @@
+DIST PyContracts-1.7.6.tar.gz 58711 SHA256 94814b376b168483edeee33fdf1a04d892065d0bdfe0638d281c285d1f3e42bf SHA512 6c76e9f04e3553b2212749bb135351860d8a6e35e13f4a35f65bf7acfa14e031fec005b1f462f9948162cfcd60f4dce7d11d7fa30cb800ce199a0bf4f3b1c472 WHIRLPOOL 52da995c03bc1cb0c2dbdeaa00cbcb35e621b69a16ee0f5630207a62cca0a058d26d90acde4db6c22e785e60f9f4387caf935fac2af2e8e305d016e52a77f507
diff --git a/dev-python/PyContracts/PyContracts-1.7.6.ebuild b/dev-python/PyContracts/PyContracts-1.7.6.ebuild
new file mode 100644
index 000000000000..4309e3f2a0c8
--- /dev/null
+++ b/dev-python/PyContracts/PyContracts-1.7.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Declare constraints on function parameters and return values"
+HOMEPAGE="http://andreacensi.github.com/contracts/ https://pypi.python.org/pypi/PyContracts/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Upstream allows tests to fail
+RESTRICT=test
+
+python_test() {
+ nosetests \
+ $(python_is_python3 || echo "--ignore-files=test_py3k_annotations.py") \
+ || die
+}
diff --git a/dev-python/PyContracts/metadata.xml b/dev-python/PyContracts/metadata.xml
new file mode 100644
index 000000000000..6d57e9c7e6d8
--- /dev/null
+++ b/dev-python/PyContracts/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">coloredlogs</remote-id>
+ <remote-id type="github">xolox/python-coloredlogs</remote-id>
+ </upstream>
+</pkgmetadata>