summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-03 02:43:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-03 02:44:11 +0200
commit76450aae281ad6869e3cab97904fbd744e27467f (patch)
treeb8ef7359077ca4fac0ea2a8909f7e253d7a54f55 /dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild
parentx11-terms/xterm: Version bump to 330 (diff)
downloadgentoo-76450aae281ad6869e3cab97904fbd744e27467f.tar.gz
gentoo-76450aae281ad6869e3cab97904fbd744e27467f.tar.bz2
gentoo-76450aae281ad6869e3cab97904fbd744e27467f.zip
dev-python/SaltTesting: Version bump to 2017.6.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild')
-rw-r--r--dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild b/dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild
new file mode 100644
index 000000000000..7d1a203250f8
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2017.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"