summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-13 06:33:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-13 06:36:46 +0200
commit11721495cc35647320072fba1d8818a2c9907d92 (patch)
tree13a41c87bde9bf746293470432d2daa92d7ded9d /dev-python/a2wsgi
parentdev-python/notebook: Bump to 7.0.5 (diff)
downloadgentoo-11721495cc35647320072fba1d8818a2c9907d92.tar.gz
gentoo-11721495cc35647320072fba1d8818a2c9907d92.tar.bz2
gentoo-11721495cc35647320072fba1d8818a2c9907d92.zip
dev-python/a2wsgi: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.8.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index 5895e9b820f5..84e06bb97901 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1 +1,2 @@
DIST a2wsgi-1.7.0.tar.gz 12933 BLAKE2B 20dc3eb0a836e47cab98810fbaa343a0ac2070a0aba3e80667e32a14a72c8838acd2c3f082d4ca2ef639b37086523c2ce18020f5ec3acfa08d0b593e9cf5d196 SHA512 f2971bfebceec7a0b91fcc3d5916455917a4f05e39f61cfde8027b1e7051c21e5ba389b86b223fb9fd875471994eee3f4455c6634b5b207417d3ec13c9452f4c
+DIST a2wsgi-1.8.0.tar.gz 13775 BLAKE2B 793ccab96e66e92ee0f662f4633deaa84075d258261b4d12099e5aaa5c1d28fd23bafb7312a0599dfb434d1e5e086e3fc98dfaa7978f449115537c7c17414da2 SHA512 c0aa649fbae0a201431990c975921249fc2d8439a8552d7ebf5d48e1fd35695175d9388e17d10009deb11842ebe806e71dd59ccf9bc16b656d68bc9e6491a352
diff --git a/dev-python/a2wsgi/a2wsgi-1.8.0.ebuild b/dev-python/a2wsgi/a2wsgi-1.8.0.ebuild
new file mode 100644
index 000000000000..28c263bb7e69
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest