summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 14:08:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 14:08:46 +0200
commitca4027c0398f64391c107284b206727213a58c14 (patch)
tree939301b665a8edd15989acbc224387b963cfe1ab /dev-python/a2wsgi
parentdev-python/rich: Add missing dev-python/attrs test dep (diff)
downloadgentoo-ca4027c0398f64391c107284b206727213a58c14.tar.gz
gentoo-ca4027c0398f64391c107284b206727213a58c14.tar.bz2
gentoo-ca4027c0398f64391c107284b206727213a58c14.zip
dev-python/a2wsgi: Add missing dev-python/pytest-asyncio dep
Closes: https://bugs.gentoo.org/931989 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.4.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild
index 5e3d6a8de4f6..26de004d6e5c 100644
--- a/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild
+++ b/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild
@@ -24,7 +24,13 @@ BDEPEND="
>=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
<dev-python/httpx-1[${PYTHON_USEDEP}]
>=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}