summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-24 17:11:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-24 17:51:09 +0200
commit14d98958f7230ff60e5fc10878c059d61e61484a (patch)
treeda10ba70fc81ac706e2dcb54436354533c10deb2 /dev-python/aiofiles
parentdev-python/markdown-exec: Bump to 1.9.3 (diff)
downloadgentoo-14d98958f7230ff60e5fc10878c059d61e61484a.tar.gz
gentoo-14d98958f7230ff60e5fc10878c059d61e61484a.tar.bz2
gentoo-14d98958f7230ff60e5fc10878c059d61e61484a.zip
dev-python/aiofiles: Bump to 24.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-24.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index d0942ccbe9b5..e6ed3608c95f 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-23.2.1.tar.gz 32072 BLAKE2B 9718fe7f4367b30ca295efb39ffeab0c77ca54ed1c4f556b0b39f5abb540d4f23c6e8a49aa5b6b76c0692e393bbab7c8d252de4b0f6f4f423b74e88c43483e08 SHA512 defc9d1ff5351c1812432db1849233b1f0aa661f6420c79a6eb17d84c0622ee4dd5102d50e9ef920c91adcc48914a39cd62701b340b01806a83773bf05900b6f
+DIST aiofiles-24.1.0.tar.gz 30247 BLAKE2B a2f979feb2db577b70caa0919a5571fa1a5d5e3f8b27711db72e9307f91effedaf587ce482fbd0ebca3dcca33388db16f72ab21c001438d32fc094b052703abd SHA512 dcb7f69354899f752cf4eef63a19ca6582f9288735345a0ff7503f3dd571e0a184962fbb89054a2e46e3efff5d84db6bdec4bb421a7d0aa8fec2c3093e54c371
diff --git a/dev-python/aiofiles/aiofiles-24.1.0.ebuild b/dev-python/aiofiles/aiofiles-24.1.0.ebuild
new file mode 100644
index 000000000000..036e263b7b1f
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-24.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest