summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-06 20:47:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-06 20:49:48 +0100
commit4f5e89fb7fd5a82573e7ca8e7b54fcaa38196ee5 (patch)
tree2ef3b28777999f56dcf001351862979fd1eff94b /dev-python/aiohappyeyeballs
parentsci-mathematics/z3: Remove old (diff)
downloadgentoo-4f5e89fb7fd5a82573e7ca8e7b54fcaa38196ee5.tar.gz
gentoo-4f5e89fb7fd5a82573e7ca8e7b54fcaa38196ee5.tar.bz2
gentoo-4f5e89fb7fd5a82573e7ca8e7b54fcaa38196ee5.zip
dev-python/aiohappyeyeballs: New package, v2.3.1
A future dependency of dev-python/aiohttp. Bug: https://github.com/aio-libs/aiohappyeyeballs/issues/33 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild36
-rw-r--r--dev-python/aiohappyeyeballs/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
new file mode 100644
index 000000000000..e39deb3d9b06
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -0,0 +1 @@
+DIST aiohappyeyeballs-2.3.1.gh.tar.gz 46348 BLAKE2B 6d20cd6db085b7d7bd0b2a18eec01dbd569eb64be7ae953eadcd07e161442637fee9ec63c3bb2253d11fea210d9ab6e8a130f9f036652a8965325db9fc30d3dd SHA512 c02a12a269e0733f653df9fedc150aea8ad061fb8b1f67e3519d6c2e8ea92f8ad3360b4eaacc0e55f51e81f57cc9c8aa82dbe0fcd9779dcd8151a3f944f28847
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild
new file mode 100644
index 000000000000..93d57735e419
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}
diff --git a/dev-python/aiohappyeyeballs/metadata.xml b/dev-python/aiohappyeyeballs/metadata.xml
new file mode 100644
index 000000000000..5f0349700b9f
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">aio-libs/aiohappyeyeballs</remote-id>
+ <remote-id type="pypi">aiohappyeyeballs</remote-id>
+ </upstream>
+</pkgmetadata>