summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-11 19:56:03 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-11 19:56:28 -0600
commit541bcacad770afb2f6296cf766294e17cd5dbec4 (patch)
tree694826c95cfd9512a0b5736f6ebc3d0cc5161938 /dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
parentx11-terms/terminator: add chutzpah as maintainer (diff)
downloadgentoo-541bcacad770afb2f6296cf766294e17cd5dbec4.tar.gz
gentoo-541bcacad770afb2f6296cf766294e17cd5dbec4.tar.bz2
gentoo-541bcacad770afb2f6296cf766294e17cd5dbec4.zip
Revert "dev-python/aiosmtpd: Clean old up"
This reverts commit 6a096a85b582a3c4de9bf24624d4897d71a3c822.
Diffstat (limited to 'dev-python/aiosmtpd/aiosmtpd-1.0.ebuild')
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
new file mode 100644
index 000000000000..8595ce17c0db
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ rm -r examples
+ distutils-r1_python_prepare_all
+}