summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-24 08:23:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-24 08:41:43 +0200
commit944849c20a1b598b11bd7348748f7147bb6bf6fc (patch)
treed29a8e5564a53d26cc440ff28695c2699ce92299 /dev-python/alembic
parentdev-python/fonttools: Bump to 4.54.0 (diff)
downloadgentoo-944849c20a1b598b11bd7348748f7147bb6bf6fc.tar.gz
gentoo-944849c20a1b598b11bd7348748f7147bb6bf6fc.tar.bz2
gentoo-944849c20a1b598b11bd7348748f7147bb6bf6fc.zip
dev-python/alembic: Bump to 1.13.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.13.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index ee45ec812186..2a8bcfbba4d8 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.13.2.tar.gz 1206463 BLAKE2B edff3a244fa37556cd656e60940d94e7df75b6c67aa4199b673851b5b06e84dbf51e53f2ac9781465aa923c0019fcd33a9c3b4da90d64f583956e390ca1f5fa7 SHA512 c4952123ba00403bb030606c736dab8d5494b01662d02914fb0d10d0c1d99b27a97cc4a800cdfa32d53870031c46e351f97815e337c71f3a0a824b6403bd75cf
+DIST alembic-1.13.3.tar.gz 1921223 BLAKE2B 25f0dcc806e5988e54f2557bce31bdb50ff94ea6a312fa71a82f61114b4b34a5a2b8003c8174d77a4e202c60d84f8cad4b61c048b093e2159a6dd85ca8f38ce1 SHA512 5661098833a4314484a6e7ea4cdea9755ed84982eaa914972265943c8b62e17d5a2831d323d238c4a37d71de61251388d43f5b419e2c592753f6bdc5fc463563
diff --git a/dev-python/alembic/alembic-1.13.3.ebuild b/dev-python/alembic/alembic-1.13.3.ebuild
new file mode 100644
index 000000000000..cf8af9852135
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-libs/timezone-data
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}