summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-30 18:35:30 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-30 18:39:11 -0400
commitb863cc0ef6540dff5e32c721e5f1f35ed376c163 (patch)
tree7c83d0de07946012ff15de902b4d676d167530b8 /dev-python/aniso8601/aniso8601-1.2.0.ebuild
parentdev-python/setuptools: version bump to 28.7.1 (diff)
downloadgentoo-b863cc0ef6540dff5e32c721e5f1f35ed376c163.tar.gz
gentoo-b863cc0ef6540dff5e32c721e5f1f35ed376c163.tar.bz2
gentoo-b863cc0ef6540dff5e32c721e5f1f35ed376c163.zip
dev-python/aniso8601: version bump to 1.2.0
Diffstat (limited to 'dev-python/aniso8601/aniso8601-1.2.0.ebuild')
-rw-r--r--dev-python/aniso8601/aniso8601-1.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/aniso8601/aniso8601-1.2.0.ebuild b/dev-python/aniso8601/aniso8601-1.2.0.ebuild
new file mode 100644
index 000000000000..8538bde96a45
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.python.org/pypi/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}