summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-10 10:50:04 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-10 11:58:13 +0200
commit4988fd0c3cd4efafb5a961eb4c98170a0dbb1a7f (patch)
tree0cc574394e6100a0f8288eb285d7a2ce04a43b4d /dev-python/anyio
parentapp-admin/ansible-lint: drop old (diff)
downloadgentoo-4988fd0c3cd4efafb5a961eb4c98170a0dbb1a7f.tar.gz
gentoo-4988fd0c3cd4efafb5a961eb4c98170a0dbb1a7f.tar.bz2
gentoo-4988fd0c3cd4efafb5a961eb4c98170a0dbb1a7f.zip
dev-python/anyio: import from ::guru
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-3.1.0.ebuild42
-rw-r--r--dev-python/anyio/metadata.xml34
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
new file mode 100644
index 000000000000..d37dd4e27036
--- /dev/null
+++ b/dev-python/anyio/Manifest
@@ -0,0 +1 @@
+DIST anyio-3.1.0.tar.gz 122097 BLAKE2B 4a16a5d231cc5262dd4138f628b9d210180733bda4b9e81ced0c0e0c7f49e1760c8dd22db0a1db3b7a21f3210072f4e1c543e52a7dc716ad3f0415827da48e38 SHA512 120d8e3e24f542c06caedd0a67d16b3fb69c94f5feaebde5262e54f8ffba3f1cf927c82030d65fa2efb3479ee64abd968b6ce67aee767ea33ccef6b0e3fbd358
diff --git a/dev-python/anyio/anyio-3.1.0.ebuild b/dev-python/anyio/anyio-3.1.0.ebuild
new file mode 100644
index 000000000000..53b2893ab605
--- /dev/null
+++ b/dev-python/anyio/anyio-3.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio
+ https://pypi.org/project/anyio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# This will pull in dev-python/trio and a whole bunch of other new things
+# And trio does not yet have a release compatible with python3.9.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
diff --git a/dev-python/anyio/metadata.xml b/dev-python/anyio/metadata.xml
new file mode 100644
index 000000000000..99d53f711918
--- /dev/null
+++ b/dev-python/anyio/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <longdescription lang="en">
+AnyIO is a asynchronous compatibility API that allows applications and libraries written against it to run unmodified on asyncio, curio and trio.
+
+It bridges the following functionality:
+
+Task groups
+Cancellation
+Threads
+Signal handling
+Asynchronous file I/O
+Subprocesses
+Inter-task synchronization and communication (locks, conditions, events, semaphores, object streams)
+High level networking (TCP, UDP and UNIX sockets)
+You can even use it together with native libraries from your selected backend in applications. Doing this in libraries is not advisable however since it limits the usefulness of your library.
+
+AnyIO comes with its own pytest plugin which also supports asynchronous fixtures. It even works with the popular Hypothesis library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">agronholm/anyio</remote-id>
+ <remote-id type="pypi">anyio</remote-id>
+ <maintainer status="unknown">
+ <email>alex.gronholm@nextday.fi</email>
+ <name>Alex Grönholm</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>