summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-27 16:38:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-27 16:38:00 +0200
commitb363c07bb5d2153ae3863ea39d0ae592f3cc42ce (patch)
tree768ccebc2ffb0c4731d5f8ac318f0d69ef660a95 /dev-python/apsw/apsw-3.46.1.0.ebuild
parentdev-python/oslo-config: Bump to 9.6.0 (diff)
downloadgentoo-b363c07bb5d2153ae3863ea39d0ae592f3cc42ce.tar.gz
gentoo-b363c07bb5d2153ae3863ea39d0ae592f3cc42ce.tar.bz2
gentoo-b363c07bb5d2153ae3863ea39d0ae592f3cc42ce.zip
dev-python/apsw: Bump to 3.46.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw/apsw-3.46.1.0.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.46.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/apsw/apsw-3.46.1.0.ebuild b/dev-python/apsw/apsw-3.46.1.0.ebuild
new file mode 100644
index 000000000000..7b49484a85a9
--- /dev/null
+++ b/dev-python/apsw/apsw-3.46.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}