summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 18:35:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 19:13:06 +0200
commitdc414511a5b92b27cd3d890f62c6cd504b78e8db (patch)
tree131fe65f99d941d03d1cef12cc5cbf45b2fdd617 /dev-python/argcomplete
parentsys-kernel/asahi-sources: add 6.8.9_p5 (diff)
downloadgentoo-dc414511a5b92b27cd3d890f62c6cd504b78e8db.tar.gz
gentoo-dc414511a5b92b27cd3d890f62c6cd504b78e8db.tar.bz2
gentoo-dc414511a5b92b27cd3d890f62c6cd504b78e8db.zip
dev-python/argcomplete: Fix test flakiness
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/argcomplete-3.3.0.ebuild2
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-3.3.0.ebuild b/dev-python/argcomplete/argcomplete-3.3.0.ebuild
index cdda946da90b..ab7a1bf05da6 100644
--- a/dev-python/argcomplete/argcomplete-3.3.0.ebuild
+++ b/dev-python/argcomplete/argcomplete-3.3.0.ebuild
@@ -36,6 +36,8 @@ PATCHES=(
# for entry point tests because they read metadata of all installed
# packages which can take real long on systems with lots of packages
"${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+ # https://github.com/kislyuk/argcomplete/pull/485
+ "${FILESDIR}/${P}-test-bashrc.patch"
)
python_test() {
diff --git a/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch b/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch
new file mode 100644
index 000000000000..0e9f2fa1cea6
--- /dev/null
+++ b/dev-python/argcomplete/files/argcomplete-3.3.0-test-bashrc.patch
@@ -0,0 +1,13 @@
+diff --git a/test/test.py b/test/test.py
+index c8f9419..ca38be6 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -73,7 +73,7 @@ def _repl_sh(command, args, non_printable_insert):
+
+
+ def bash_repl(command="bash"):
+- bashrc = os.path.join(os.path.dirname(pexpect.__file__), "replwrap", "bashrc.sh")
++ bashrc = os.path.join(os.path.dirname(pexpect.__file__), "bashrc.sh")
+ sh = _repl_sh(command, ["--rcfile", bashrc], non_printable_insert="\\[\\]")
+ return sh
+