summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-10 07:13:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-10 07:25:08 +0100
commitffa4095f2f124cdfdaa553d644f5bbfc5c40f3cd (patch)
tree087d28e033f818c2ee52788dd4b76b4fd22b12b2 /dev-python/argcomplete
parentdev-python/tifffile: Bump to 2023.12.9 (diff)
downloadgentoo-ffa4095f2f124cdfdaa553d644f5bbfc5c40f3cd.tar.gz
gentoo-ffa4095f2f124cdfdaa553d644f5bbfc5c40f3cd.tar.bz2
gentoo-ffa4095f2f124cdfdaa553d644f5bbfc5c40f3cd.zip
dev-python/argcomplete: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.2.0.ebuild43
-rw-r--r--dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch5
3 files changed, 45 insertions, 4 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 98a177d7c6ee..62a41d2b60ec 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1 +1,2 @@
DIST argcomplete-3.1.6.tar.gz 79685 BLAKE2B df21d5a68a173a3c09b76d866adf949910ad775eb6c7d09d797308e87c128a6eebe173d89fc95aaa42bb87bf08e9c84aa217e8844c9fab5c680c83e07d0c7854 SHA512 7d625dfc49253281f692254a23e7fc4af155b97a7df55a0b33eba9655281702396a1119269cf80b5650885e00d75886fbdcbd85312e7ccac6d940edd6189d50e
+DIST argcomplete-3.2.0.tar.gz 80524 BLAKE2B cbe15faf0c46f761204f004a4b630efbb037444a7222c9fcd59dafa7f2d8201edade374cf70fe3a059d3681ef320942dd3b43f0984c04a2cd52fe0571dafce6c SHA512 4ec4b83f68080cf8710b7377ae377a8ae10bc54f46bdd2a825b4c04d80a8d42f63fbc04d6413e2c430d7f4024ecd42f944b102c70e3fa3b60afda10a33994ac7
diff --git a/dev-python/argcomplete/argcomplete-3.2.0.ebuild b/dev-python/argcomplete/argcomplete-3.2.0.ebuild
new file mode 100644
index 000000000000..691d9d9b7d84
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}
diff --git a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
index d8348818164d..0b2ac120402e 100644
--- a/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
+++ b/dev-python/argcomplete/files/argcomplete-3.1.6-timeout.patch
@@ -2,10 +2,7 @@ diff --git a/test/test.py b/test/test.py
index c89912a..eedfe36 100755
--- a/test/test.py
+++ b/test/test.py
-@@ -1359,7 +1359,7 @@ class TestBashGlobal(TestBash):
- if sys.platform == "darwin":
- # Work around https://stackoverflow.com/questions/24257803
- command += ' --install-option="--prefix="'
+@@ -1362,4 +1362,4 @@ class TestBashGlobal(TestBash):
- install_output = self.sh.run_command(command)
+ install_output = self.sh.run_command(command, timeout=300)
self.assertEqual(self.sh.run_command("echo $?"), "0\r\n", install_output)