summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-19 19:20:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-19 20:27:49 +0200
commit4802d70ad6a79d82ecb1fca28ecf238f32e1641f (patch)
treed28e398518fe36dae1151caa84fbecbdead08fa6 /dev-python/argh
parentdev-lang/ruby: dev-util/systemtap is now dev-debug/systemtap (diff)
downloadgentoo-4802d70ad6a79d82ecb1fca28ecf238f32e1641f.tar.gz
gentoo-4802d70ad6a79d82ecb1fca28ecf238f32e1641f.tar.bz2
gentoo-4802d70ad6a79d82ecb1fca28ecf238f32e1641f.zip
dev-python/argh: add 0.31.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.31.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index cd3085f4f510..0509164b7252 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1 +1,2 @@
DIST argh-0.31.0.tar.gz 65743 BLAKE2B c577273bf361b0bede939b7bcadf9c9ce6dd24d473b834ebd8d2bdc41d163e9cb6f2b79252ab810ac5b6f1f2e20b312cf096b23cf6cd4cd53705fb2c30b55f7d SHA512 d4caefede2596452d3256f4c2194517994dffdb2e01643f0b96b8002d269ac0150e938bb29d0469b67bbb72669b2a82b3e66d28cfecad5230f641c60f1c879e5
+DIST argh-0.31.1.tar.gz 57186 BLAKE2B a6167b6b1c18cb9ab50f476d39783e4f26aa57a25a2d503465c617b1f6adf72eb8a0ec6df3235a73dc443eaa413819b986bd290e3d093099f54abd349fe8b533 SHA512 cd4bb989e96587c1a0bdf9854164b6bc4cb35e529c19d4812741529f9ad880019ed4691fc2b02c49264dd0cc3f8a10400f7272f7ba9a1979cb5268bbbe83f3a7
diff --git a/dev-python/argh/argh-0.31.1.ebuild b/dev-python/argh/argh-0.31.1.ebuild
new file mode 100644
index 000000000000..7fce261a4518
--- /dev/null
+++ b/dev-python/argh/argh-0.31.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest