summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-11 16:54:28 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-11 16:55:00 +0800
commit17db9eb9aedbc67d55496d5c8303cfc48acd763e (patch)
tree137932e83b19e1db69c768d2c47923adb130e4c6 /dev-python/astor
parentRevert "sci-libs/tensorflow: drop unneeded dep for zip" (diff)
downloadgentoo-17db9eb9aedbc67d55496d5c8303cfc48acd763e.tar.gz
gentoo-17db9eb9aedbc67d55496d5c8303cfc48acd763e.tar.bz2
gentoo-17db9eb9aedbc67d55496d5c8303cfc48acd763e.zip
dev-python/astor: bump 0.8.1
Add python3_8 and switch testrunner to pytest Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-python/astor')
-rw-r--r--dev-python/astor/Manifest1
-rw-r--r--dev-python/astor/astor-0.8.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/astor/Manifest b/dev-python/astor/Manifest
index da3ec8f5a3f8..89c4d7a98a66 100644
--- a/dev-python/astor/Manifest
+++ b/dev-python/astor/Manifest
@@ -1,3 +1,4 @@
DIST astor-0.5.tar.gz 10999 BLAKE2B 278bf193003dd9f8f2d5c6a33229e3f4013bcf0618dee1d8cc3891ffea031f63ad4f795a3b66e87986bcf377b5f81eb6992d3c47c2234357487443a049d45d31 SHA512 7c940371a6c3ddbc4a6691edb6ee17eef61436912bb873c5c0cba4f3865c9d4f8e077674b14ccc7e319b749898782aaf87e085eedd9ba7f8638130deb67f549b
DIST astor-0.6.tar.gz 28684 BLAKE2B 372314e0d92721d3cbb7fe0fe8bc42635e023ca590c4845c8e7c499bc947c3de0a3679fff51a07085d26bca37e83301ef9c0b66548b929a8f018760c8370319c SHA512 4f9598229f8a77901573fa1841716cc810ec8e108b155d8c7c50ab477d794f8ecd1784df66a1272a2739cc968d8eb6632f62b4d6ef067682db05233f127be409
DIST astor-0.7.1.tar.gz 30633 BLAKE2B fbffcbe9cb372c82741788624674c4397c3534eb2b3f44577174279c38d0c45366b444dab1384a251a74ca87840ce150ab1ce3f0439987ba2a19adca270af74f SHA512 c52fa0b8ec5003c04d978c23361d423283a43be2c027d8d39ce1c45528dbbedb98b2a269ce97152bd9a4c942d95a6ec55720757b7811df4f34bb6744e2fff781
+DIST astor-0.8.1.tar.gz 35090 BLAKE2B 11e5e77d4f8a8617d0330d3091a1571744bb5773df926f41b10208e1c5beb7e82ad8961a460dd326e9130591dade495c77a36456618a97a5c22e41237805a4ce SHA512 cfc69a21fcbc9842bc26fbe8372e5c700d9957cc0c3c62de415155d2036163951f0ece88557829afd7c4dabba8a8e238a2335994ddfc020cb3db913eed5b6f28
diff --git a/dev-python/astor/astor-0.8.1.ebuild b/dev-python/astor/astor-0.8.1.ebuild
new file mode 100644
index 000000000000..c4da9ca17c5b
--- /dev/null
+++ b/dev-python/astor/astor-0.8.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://pypi.org/project/astor/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Tries to roundtrip every package on the system and is unreliable
+ rm -f tests/test_rtrip.py || die
+
+ distutils-r1_python_prepare_all
+}