summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-15 07:12:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-15 07:57:55 +0200
commit5936cd3098845183f089c6e67d8543e5760f03cb (patch)
tree444ad92382018b2f6a6382843c51053ff44e19f5 /dev-python/astroid
parentdev-python/json5: Bump to 0.9.14 (diff)
downloadgentoo-5936cd3098845183f089c6e67d8543e5760f03cb.tar.gz
gentoo-5936cd3098845183f089c6e67d8543e5760f03cb.tar.bz2
gentoo-5936cd3098845183f089c6e67d8543e5760f03cb.zip
dev-python/astroid: Bump to 2.15.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.15.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index cb4777aa7d05..f48397826226 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1 +1,2 @@
DIST astroid-2.15.4.gh.tar.gz 461609 BLAKE2B 0dc54a0a99c16698e025f01361d67a5aa248e091f757184bfeb8b6287d656afbb56706a99058c0105252c6925dbe51e8ee260020d7512d7aa9bbf3d92d0a0b7e SHA512 1725676cd55fde0359e7210b917663fa82a87bbec052fda27a80a08e7d2308ab1de7a5c1f1a052fd76575d9945d55743e6c23684754e03e84bb2facb51f2a5a2
+DIST astroid-2.15.5.gh.tar.gz 461755 BLAKE2B 4af28becb14d767c3fa162be93cd1d3f99e42a476a7b1ee57225a6d5603876cbfde7a58e17412d1142baa42288cbb2cfe3ecdbaafe5195c777f04a3ad9fe4427 SHA512 9862a2f4703b36284d14a3b09f80b4b0a1e0948e306b4906ec663fc133d07966e24a711a90067b369b166ce4d53859327e1da84406a023d1a911fff7bb0ed026
diff --git a/dev-python/astroid/astroid-2.15.5.ebuild b/dev-python/astroid/astroid-2.15.5.ebuild
new file mode 100644
index 000000000000..553be35505ca
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ # requires pip, and looks suspicious anyway
+ tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}