summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 14:00:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 14:32:32 +0200
commitf53cd7c6730a0a2ce268e7fad49017dd205146c0 (patch)
tree18f7f9ed8d1c19b3c2c3d585c856686dfb230d56 /dev-python/asyncstdlib
parentmedia-sound/cmus: Stabilize 2.11.0 amd64, #934457 (diff)
downloadgentoo-f53cd7c6730a0a2ce268e7fad49017dd205146c0.tar.gz
gentoo-f53cd7c6730a0a2ce268e7fad49017dd205146c0.tar.bz2
gentoo-f53cd7c6730a0a2ce268e7fad49017dd205146c0.zip
dev-python/asyncstdlib: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild21
1 files changed, 19 insertions, 2 deletions
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild
index a119efae5be7..b9853014080d 100644
--- a/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild
+++ b/dev-python/asyncstdlib/asyncstdlib-3.12.3.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-# py3.13: https://github.com/maxfischer2781/asyncstdlib/issues/144
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -26,3 +25,21 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/maxfischer2781/asyncstdlib/issues/144
+ # (already skipped upstream)
+ 'unittests/test_functools_lru.py::test_method_discard[classmethod_counter-3]'
+ 'unittests/test_functools_lru.py::test_method_discard[classmethod_counter-10]'
+ 'unittests/test_functools_lru.py::test_method_discard[classmethod_counter-None]'
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}