summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-26 07:26:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-26 07:27:36 +0200
commit8af09017a38ab9bbee2e2a0661a192402061febe (patch)
treeebe96528a517ebb10f379c9e05efd6115d29a4f4 /dev-python/autopep8
parentdev-python/mkdocstrings-python: Bump to 1.5.2 (diff)
downloadgentoo-8af09017a38ab9bbee2e2a0661a192402061febe.tar.gz
gentoo-8af09017a38ab9bbee2e2a0661a192402061febe.tar.bz2
gentoo-8af09017a38ab9bbee2e2a0661a192402061febe.zip
dev-python/autopep8: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.0.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 4f71b2b72ab9..76e286b4e219 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-2.0.2.tar.gz 116154 BLAKE2B 1b6830f9cb8a4384898273411f6b03cf3e3c0e45e2c56fa2bb134f3567cc06459a8123e660db9252f8d7cd15835d70e54c0155f146191be64ffbafaaa808244d SHA512 09471827d18ca0c691bc524e0639a416d1a4418ddda1cb88f50e5c5302e75e7014751e659e26439c22317db21588fbd956c94299cef44e2c47771df38de94be3
+DIST autopep8-2.0.3.tar.gz 116499 BLAKE2B f43476babe717ccd1d8ea363dc00e8a1227433078c89662c92097b2e569c9da46ad14af4e42982289bf6ec6cfc88f4db233b638dcf89f882fd7c4650f3f70160 SHA512 0007d6c6a17f21e1b4e00d1b69d83cac6db50a4c17ae351a429275958adcbb1d014e0f7e7e966239cc47388cb15ec07a3569f1254c1f16ebf6fb7d43fcfe57e6
diff --git a/dev-python/autopep8/autopep8-2.0.3.ebuild b/dev-python/autopep8/autopep8-2.0.3.ebuild
new file mode 100644
index 000000000000..1d0c3278faab
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to deprecation warnings
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
+ )
+
+ epytest
+}