summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-19 20:08:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-19 20:08:04 +0300
commit429ee757d193dc71ac56b63577f0892eac3fe466 (patch)
tree17cf47a7e1ffbf60630763180151a5098d93524d /dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
parentsci-physics/yoda: Remove old (diff)
downloadgentoo-429ee757d193dc71ac56b63577f0892eac3fe466.tar.gz
gentoo-429ee757d193dc71ac56b63577f0892eac3fe466.tar.bz2
gentoo-429ee757d193dc71ac56b63577f0892eac3fe466.zip
dev-python/aws-xray-sdk-python: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild')
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild40
1 files changed, 19 insertions, 21 deletions
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
index 560c3e416dac..d07a31c0dce9 100644
--- a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
+++ b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.8.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,7 +16,6 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
>=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
@@ -33,6 +33,10 @@ BDEPEND="
dev-python/webtest[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10-loops.patch"
+)
+
distutils_enable_tests pytest
python_test() {
@@ -40,34 +44,28 @@ python_test() {
local -x AWS_SECRET_ACCESS_KEY=fake_key
local -x AWS_ACCESS_KEY_ID=fake_id
- local args=(
- # unpackaged deps
- --ignore tests/ext/aiobotocore
- --ignore tests/ext/pg8000
- --ignore tests/ext/psycopg2
- --ignore tests/ext/pymysql
- --ignore tests/ext/pynamodb
- --ignore tests/ext/sqlalchemy_core/test_postgres.py
- --deselect tests/ext/django/test_db.py
-
+ local EPYTEST_DESELECT=(
# Internet access
- --deselect
tests/test_patcher.py::test_external_file
- --deselect
tests/test_patcher.py::test_external_module
- --deselect
tests/test_patcher.py::test_external_submodules_full
- --deselect
tests/test_patcher.py::test_external_submodules_ignores_file
- --deselect
tests/test_patcher.py::test_external_submodules_ignores_module
- --deselect
tests/ext/aiohttp/test_client.py
- --ignore
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged deps
+ tests/ext/aiobotocore
+ tests/ext/pg8000
+ tests/ext/psycopg2
+ tests/ext/pymysql
+ tests/ext/pynamodb
+ tests/ext/sqlalchemy_core/test_postgres.py
+ tests/ext/django/test_db.py
+ # Internet access
tests/ext/httplib
- --ignore
tests/ext/requests
)
- epytest -p no:django "${args[@]}"
+ epytest -p no:django
}